View Full Version : network card: SIOCSIFFLAGS:device or resource busy?????

09-24-2003, 04:22 PM
I'm trying knoppix, it looks like nice but I have a problem:
when I try to configure mt ethernet card (it is recognized, I see it in the boot part) giving my IP address and the gateway and Name server (DNS, I suppose), it gives me back this message:SIOCSIFFLAGS:device or resousce busy. I got no idea.
I just can tell that ifconfig says:
lo link encap: local loopback
inet addr: mask
UP loopback running

I also tried to do ifconfig eth0 netmask up but same message.

Any idea??

My PC is installed on a Microsoft lan (win2k), with workgroup and NT domain.

In my lan settings (win2k) I have: IP addr, WINS, gateway and DNS
Looks like not being so easy.. but I'm green at this.
Thanks for helping
Simone from Italy

09-29-2003, 10:55 PM
Souinds like perhaps an IRQ conflict. Try cat /proc/interrupts and see if that's what's going on. Can you disable PnP in the BIOS? You are using static ip's on your network? What kind of network card?

09-30-2003, 01:58 PM
I'm using static ip's on my network , the network card is an Intel pro/100 VM Netwprk connection, and it's seen as Intel Etherexpress pro/100 under linux.

What should I check for in cat /proc/interrupts??

My PC is a Compaq Evo W4000 with scsi card for HP scanner, Audigy audio card and radeon 8500 video card.

I think I can turn the bios option PnP in the BIOS off. Gonna try.

I first thought the driver was not correctly installed, but also Mandrake and Suse recognize the network card this way. So maybe it's a irq problem. I'd know exactly how to solve it under Win2k, but under Linux...
Thanks a lot

09-30-2003, 04:14 PM
This is the result of the ifconfig, ifconfig eth0 and cat/proc/interrupts

svpg024:/home/simper # ifconfig
lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:66 errors:0 dropped:0 overruns:0 frame:0
TX packets:66 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4316 (4.2 Kb) TX bytes:4316 (4.2 Kb)

svpg024:/home/simper # ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:02:A5:F4:F4:9A
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Base address:0x1400 Memory:fc404000-fc404038

svpg024:/home/simper # ifconfig eth0 up
SIOCSIFFLAGS: Dispositivo o risorsa occupata
SIOCSIFFLAGS: Dispositivo o risorsa occupata

svpg024:/home/simper # cat /proc/interrupts
0: 86724 XT-PIC timer
1: 884 XT-PIC keyboard
2: 0 XT-PIC cascade
5: 1 XT-PIC ohci1394, usb-uhci
8: 4 XT-PIC rtc
10: 573 XT-PIC usb-uhci
12: 24463 XT-PIC PS/2 Mouse
14: 4206 XT-PIC ide0
15: 24455 XT-PIC ide1
NMI: 0
LOC: 0
ERR: 0
MIS: 0
svpg024:/home/simper #

Ah, finally: I can't turn pnp from Compaq bios...
Look like it's VERY hard for a standard machine to make linux work in a local network...
Hope I'm wrong

10-22-2003, 05:20 AM
change a pci slot.
i done it by changing the pci slot.
good luck. :twisted: