View Full Version : KNOPPIX_V3.3-2003-09-24: Intel 845 Graphic Card Problem

09-25-2003, 02:35 PM

I just burned the new KNOPPIX 3.3 iso and with this version the integrated i845 graphic card can not go into 1280x1024 (XFree i810 driver) ...

After boot and detecting all the hardware I get this messages:
[drm:drm_init] *ERROR* Cannot initialize the agpgart module. /lib/modules/2.4.22-xfs/kernel/drivers/char/drm/i810.o: init_module: Cannot allocate memory Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg /lib/modules/2.4.22-xfs/kernel/drivers/char/drm/i810.o: insmod /lib/modules/2.4.22-xfs/kernel/drivers/char/drm/i810.o failed /lib/modules/2.4.22-xfs/kernel/drivers/char/drm/i810.o: insmod i810 failed
Are some kind of solution for this?. This does'nt happen with KNOPPIX 3.2 :-(

10-20-2003, 12:35 PM
Confirming this behaviour on i845 chipset. Any fix please?

11-03-2003, 11:10 AM
I have exactly the same problem with I865G. Anyone has a solution ?

03-14-2004, 05:23 AM
I don't this is the forum to discuss the issue. However, I'd like to add my two bits from my own experience yesterday.

I installed Knoppix (Debian) on the hard disk and I faced this problem too, but here's the confusing part. The problem surfaced only when I used a single 512 MB RAM chip. The problem went away when I switched it with a 128 MB RAM chip.

Note: The problem does not appear when I run Knoppix Live on the CD with 128 or 512 MB RAM.

Weird huh!

Worst part... the damn thing works fine on Red Hat 9. :-(

So I was unable to use Knoppix since I ran out of time. :-(