PDA

View Full Version : Network card Problem



lilliput
01-24-2003, 03:06 AM
My ladtod has a 10/100 network card but on windows with every drivers that I've test it work only on the 10 mbps half duplex mode
Since 3 days the nettwork card doesn't want to communicate on Knoppix with the CDRom (very strange !!!) (On windows it works and I use it to access to internet througt an another computer)

So I give you all important information that you could require to help me.
I've try to change the media type with ifconfig butt it doesn't seem to work too. So unfortunatly I have to reboot at every time.

ifconfig
eth0 Lien encap:Ethernet HWaddr 00:A0:CD:D7:4D:67
inet adr:192.168.0.5 Bcast:192.168.0.255 Masque:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:9 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:100
RX bytes:783 (783.0 b) TX bytes:3078 (3.0 KiB)
Interruption:9 Adresse de base:0xc700

.......
__________________________________________________ ________


root@ttyp0[hda5]# ping 192.168.0.3 -----(it's my gateway )
PING 192.168.0.3 (192.168.0.3): 56 data bytes
--- 192.168.0.3 ping statistics ---
72 packets transmitted, 0 packets received, 100% packet loss

root@ttyp0[hda5]# ping 192.168.0.5 --------- (that's me so TCP/IP work)
PING 192.168.0.5 (192.168.0.5): 56 data bytes
64 bytes from 192.168.0.5: icmp_seq=1 ttl=64 time=0.0 ms
--- 192.168.0.5 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0.0/0.0/0.1 ms
__________________________________________________ _

change media type ...

root@ttyp0[hda5]# ifconfig eth0 media 10baseT
port: SIOCSIFMAP: Opération non supportée

root@ttyp0[hda5]# ifconfig eth0 media 10base2
port: SIOCSIFMAP: Opération non supportée

root@ttyp0[hda5]# ifconfig eth0 media auto
auto: Erreur de repérage du nom de l'hôte cible

__________________________________________________ ____
__________________________________________________ ____

lspci -vv

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 51)
Subsystem: Uniwill Computer Corp: Unknown device 8100
Flags: bus master, medium devsel, latency 32, IRQ 9
I/O ports at d000 [size=256]
Memory at dffff700 (32-bit, non-prefetchable) [size=256]
Capabilities: [40] Power Management version 2

lspci -n
00:00.0 Class 0600: 1106:0305 (rev 80)
00:01.0 Class 0604: 1106:8305
00:08.0 Class 0607: 1217:6972
00:10.0 Class 0c00: 1106:3044 (rev 46)
00:11.0 Class 0601: 1106:8231 (rev 10)
00:11.1 Class 0101: 1106:0571 (rev 06)
00:11.2 Class 0c03: 1106:3038 (rev 1e)
00:11.3 Class 0c03: 1106:3038 (rev 1e)
00:11.4 Class 0680: 1106:8235 (rev 10)
00:11.5 Class 0401: 1106:3058 (rev 40)
00:11.6 Class 0780: 1106:3068 (rev 20)
00:12.0 Class 0200: 1106:3065 (rev 51)
01:00.0 Class 0300: 5333:8d02 (rev 01)

some extract from dmesg

NETDEV WATCHDOG: eth0: transmit timed out
eth0: Transmit timed out, status 0000, PHY status 786d, resetting...
eth0: reset did not complete in 10 ms.
eth0: reset did not complete in 10 ms.

thanks to help me.

Lilliput