View Full Version : Won't Boot

10-01-2003, 12:27 AM
My friend and I both have Laptops from AJP (www.ajp.co.uk)
His is the AJP 8880E and mine is the D480W

He downloaded Knoppix 3.3 because he needed to get into a folder he locked himself out of (don't ask) in NTFS and that worked fine.

The spec on my laptop is very similar to his:
- same processor
- same graphics card
- similar sound
- different LCD screen

But on mine whenever I try to boot Knoppix the screen goes blank and there is no CD activity. No even the penguin at the top of the screen :-(

Is there anything I can try? Any BIOS settings or cheatcodes I should specifically try? Or is it hopeless? I'm a complete linux novice BTW if you hadn't noticed.


10-01-2003, 04:55 AM
Welcome Mr_B43,

My first guess is memory.

Please list as much specific information
as possible.

The age old question goes:

Why doesn't my goose
Sing as well as thy goose
When I paid for my gooes
Twice as much as thine? :wink:

Serach this forum for memory links such as:
Best Wishes

10-01-2003, 10:40 AM
Ah yeh now you mention it there is a difference in the memory
His is running 512MB of DDR266 in 256MBx2
Mine is running 1GB of DDR300 in 512Mbx2

Does this help at all?

10-02-2003, 04:46 AM

So much for the memory theory -- wow
I am envious -- 1GB of DDR300!

Lets work on the BIOS.
Be sure you have boot from CD first.

Is the CD valid -- check it on another machine
or check the md5sum of the iso file if
you made your own CD.

One more test idea-- make a boot
floppy from the boot.img on the
CD. What does it do?

Best Wishes

10-06-2003, 05:16 PM
Sorry about the slow reply, I just moved to uni.

Yeh it boots from the CD fine, because the cheat entry screen comes up fine. The problem is after that nothing happens at all. There is nothing on the screen, no CD activity. I have tried the CD in two other machines, one a laptop and one a PC and they both worked fine with this exact CD.

I'll try the floppy boot and get back to you. I don't have a floppy at hand at the mo. Will it make a difference from booting from CD though?

Thanks for your help so far though.

10-08-2003, 05:41 PM
I tried using topologilinux as well that creates an image file for linux to use in an existing NTFS partition but that hangs as well but it is a little more descriptive

It says that its trying to enable a PCI card I think (writing this away from my machine)
Any suggestions?

10-09-2003, 05:07 AM
Hello Mr_B43,

I would not do anything with NTFS. Some have said
you can look at files but writing to NTFS is dangerous.

If you are interested in liunx on that machine,
perhaps you can get a second hard drive.

Search the forum for NTFS but be cautious.

On the humerous side, if you do crash your
computer, you might find some time to study.
Make the best of you days at the uni. :lol:

Best Wishes,

10-29-2003, 10:43 AM
I've got a D480W too but I got mine from rock direct. 512 MB 333DDR etc.

I have the exact same problem also. Booting from a known working CD, see the knoppix splash / boot screen, press enter, screen blanks and thats it. no disk or cd activity and i believe num-lock was broken too.

i tried knoppix 2 for textmode and also knoppix screen=1400x900 (since its a widescreen 17" laptop) but with no change.

anyone got any ideas ?


11-04-2003, 08:52 PM
Are we talking about machines made by Clevo ?
(they are sold under many different brands but the sticker on
the bottom of the machine usually reveals the "real" maker)

I just got myself a Clevo M410E and I'm seeing the same thing,
that is the machine freezes right after
"Loading miniroot.gz......."
When trying failsafe mode I get two more lines:

Uncompressing Linux... Ok, booting the kernel.

The same thing happens with a recent redhat CD too so
I think it's not just a knoppix issue...

11-05-2003, 04:09 AM
Hi you all,

I come from the wrong side of the pond, I guess,
to know about this brand of PC. I have heard of a
Dell problem with the BIOS not being independent
of the hard drive.

I wonder if this a case of the BIOS of these machines
not being stored on a chip? Can you get any help
from the seller? -- I can hear the no Linux support
answer already. :wink:

KNOPPIX works with so much hardware that it
is disconcerting to see non compatible PC's.

It would be nice if the purchasing public were aware
of the issues and would demand to know if the
Seriously, if a seller does not let you boot with a KNOPIX
disk, don't buy it. Even is you are buying a machine
for non Linux use, it would increase its value to know
that it could be recycled for use with a different
operating system in its old age.

Best Wishes,

11-05-2003, 03:05 PM

I have the same problem as above:
boot screen -> loading vmzlinux.... -> loading miniroot.gz....
and then the system hangs with no cd activity !

On the same pc I can boot successfully LindowsCD and Debian Woody 3.0 :-)
The Knoppix cd works fine on other machines..

The machine is a very new and powerful LCD PC, assembled by Enface (half way between desktop and laptop)

Any Idea on howto solve the problem or understanding what is going on ? (there are no error messages ...???)


PS: The company i work for just bought 4 of these machine and i'd like to let users try and maybe love linux....(and i hear knoppix is a good choice for desktop users...)

11-08-2003, 05:32 PM
Are we talking about machines made by Clevo ?
(they are sold under many different brands but the sticker on
the bottom of the machine usually reveals the "real" maker)

Yep, clevo laptop (www.clevo.com.tw) are resold by a load of uk companies.

The one i'm having a problem with is the D470W (http://www.clevo.com.tw/products/D470W.asp)

11-08-2003, 06:19 PM
In another thread someone described similar symptoms and claimed
that it works with Mandrake 8.1 with kernel 2.4.8 (which is very old)
I happened to have a set of Mandrake 8.0 disks and that also seems
to work, at least the installer gets started.
I guess we will have to try a 2.4.8 kernel without any Mandrake patches

11-08-2003, 09:33 PM
Hmm, CoolLinux 1.34a also works, with kernel 2.4.18 + some RedHat patches.
(CoolLinux is a RedHat based live CD a bit like Knoppix but it's not quite
as cool ;-) no on-the-fly decompression and less efficient hardware autodetection)

11-08-2003, 11:16 PM
have you tried knoppix vsync=60 on boot? I think the default resolution is too high for some screens

11-09-2003, 08:00 PM
Still no luck with knoppix but I did get the latest slackware (9.1 with kernel 2.4.22)
installed and it boots form the hard drive if I give "nohotplug" as a parameter to
the kernel at the boot prompt. No sound, PCMCIA , ethernet or ACPI yet
(and probably several other things I haven't checked)
but at least the X-server runs nicely. :-)

11-10-2003, 07:15 PM
Status report:
Got ACPI, ethernet, PCMCIA and sound working in slackware 9.1
Recompiling the kernel with the configuration file from knoppix,
if it locks up the same way after that it shouldn't be impossible
even for a dork like me to cook up a knoppix kernel that boots... ;-D

11-11-2003, 05:57 PM
I think I've found the problem. The default knoppix kernel has support
for SMP compiled in and that seems to cause my machine to freeze.
A kernel without the SMP code on the other hand runs just fine. :-)
I'm going to try to make a new ISO image as soon as I have time for
it unless someone else does it first ;-)
BTW, the default knoppix kernel also only supports APM, not ACPI.
Since many laptops are crippled without ACPI support I'll probably
switch that in too while I'm at it....

11-13-2003, 11:17 AM
that kernel would solve a lot of the compatibility problems on other laptops i'm thinking.

my own experience with nearly every flavour of linux trying to get my sh1tbag compaq evo n1015v working is similar to the other frustrated posts on the site. i will probably never buy another compaq anything in my life because of it. redhat can be got to work with an initial boot turning nearly everything off and then having to recompile the kernels using third party patches.

safe to say that on my first attempt with knoppix it failed, then i gave a 'nousb' option because i know the usb controller is spectacularly sh1t. from then on i've been amazed by knoppix-installed debian. first thing i did was play a divx5 video in full sound without any problems at all without having to scr3w around with anything!!!

knoppix rocks! death to winbloze!

11-13-2003, 09:18 PM
Almost there now, I get the kernel to start but now
it gets to "Accessing KNOPPIX CDROM at /dev/scd0... "
where it stops and flashes the caps-lock and scroll-lock leds.
I guess I did something wrong when generating the ISO
image. I'll look into it again tomorrow...

11-14-2003, 06:41 PM
Got it sort of working :-) I have an ISO file that on my machine seems to
work fine except that it drops out of graphical mode during startup.
If I say "startx" on the command line after the autostart has failed it seems to work. :-)
Another issue is that it is slighty oversize even tough I ripped out the demos
and pdf files. At 703 MB it still fits on most 700 MB disks though if you
use the "-overburn" switch in cdrecord.
If you want to give it a try you can do a search for "knoppix_3.3_acpi_experimental"
on the gnutella network.
The md5 sum is: ce993371e55b2b9c6658e141afd4dd8f
If you do download it, PLEASE calculate the md5 sum before burning it.
(and don't burn it if it doesn't match ;-) )

05-21-2004, 02:37 PM
Hi! my first post here :)

I own a Clevo D470v (bought in Portugal) and it came with a Knoppix 3.3 CD and it boots fine.

The only problem I have is not being able to setup the screen resolution to 1400x900.

I've tried fb1400x900 and screen=1400x900. desktop=icewm is not working either, though it's there in the knoppix-cheatcodes.txt

If you need it, I can upload the configs files so you ppl can boot.
(not the whole cd iso, sorry)

How can I screen@1400x900???

Anybody, any clue?

05-25-2004, 03:52 AM
I have been running linux on my Clevo D470V for a few months now. I am running Debian Sid, not Knoppix, so I hope you guys dont run me outa town for being too off topic. I just wanted to share what I think I know with you guys.

The boot problem: I got around this by enabling hyperthreading in the bios. Do not ask me why this works, but it definitly does. With this enabled, the box boots 2.4 and 2.6 kernels, smp or not, with no problems.

If you want to run X (I am sure that most do) you need a 2.6.5 or later kernel, or an earlier 2.6 kernel that you have patched for the agp glitch with this board.

Xfree86 4.3 (I assume that is what is in the latest knop) apparently does not support the radon 9600 directly, so I used the driver from ATI's site. Yes, its an evil closed source kernel module, Im sorry but I could not get anything else to work. ATI only supplies rpm's so I used Debian's tools to convert it to a deb.

I got X to find its good resoultion by asking it to do a resolution too high for it to do. This got the video bios to supply the manufacturer's recommended modeline to Xfree.

I had some trouble getting Xfree to recognize the touchpad with 2.6 kernels. Loading usb modules at boot seemed to fix that. Again, dont ask me why this works.

Hope this is at least a little helpful