View Full Version : Dell Inspiron 5150 boot problems: the cause.

10-03-2003, 05:00 PM
I've tried to investigate the problem, and here is my conclusions.

Knoppix boot process hangs immediately after the help page on my Dell Inspiron 5150 (with a 3.06 GHz P4M CPU, Dell BIOS ver. A24,) regardless of the parameters passed to the kernel.

So I installed a stock Debian system (Debian unstable updated daily: the system I'm using right now) in order to reproduce and possibly solve the problem.

I've been able to reproduce exactly the same problem with Debian (using the kernel-source package 2.4.22-2, and building the kernel image locally on my system using

The problem arises only when the kernel is compiled with the parameters
Local APIC support on uniprocessors and
IO-APIC support on uniprocessors set (to on.)
These parameters are CONFIG_X86_UP_APIC and CONFIG_X86_UP_IOAPIC respectively.

Note that these parameters are automatically set if one chooses to enable SMP (CONFIG_SMP,) as Knoppix does.

Note also that if you enable the above mentioned siwtches when compiling the kernel, there is no way to boot the system, even if you pass the
nopaic (and other similar) parameter(s) to lilo.

The problem is probably due to the fact that the Dell BIOS is buggy (the original BIOS shipped with my Inspiron -- ver. A0 something,) was produced by Compal (the manifacturer of the Inspiron 5150) and not by Dell, and it did not have this problem (though it had a number of other problems.) Unfortunately, when upgrading to Dell BIOS, you have no way to switch back to the original Compal BIOS.
Unfortunately Dell offers no support (and no testing) on Linux, so it is very unlikely that these problems will be corrected by them, as it should be :-(

So the only solution is either wait for a new kernel to circumvent these buggy BIOSes, or wait for Knoppix to permit to boot with different kernels, as you can't boot the kernel in any way once you've compiled it with the above mentioned parameters set :-(

Emanuele Zeppieri.

10-03-2003, 05:09 PM
Sorry: the parameter to pass to lilo to try to disable APIC is noapic of course and not nopaic, as I erroneously wrote.
The result is anyway the same: no joy unfortunately :-(

Emanuele Zeppieri.

10-03-2003, 05:52 PM
As the Dell BIOS does probably not permit to create a working mp-table, it is maybe worth to try to boot with the kernel parameter:

pirq=x,y,z, ...
(where x, y, z, ... are the correct IRQ entries for the Inspiron 5150 board.)
This is the only thing I've not tried yet (and I will never try,) since it requires a lenghty try-and-error process to find the correct IRQ entries.
Anyway it seems to me the only thing left to try.

For more info on the subject, consult the document IO-APIC.txt shipped with a stock kernel source tree and/or the linux-smp mailing list archives.

Emanuele Zeppieri.

10-03-2003, 09:39 PM
Thanks. You might want to post this info on the Knoppix developers list. There is more of a chance that it will be addressed this way.


10-06-2003, 10:23 PM
I have a Sager 5670
3.06GHz with ht
1GB Ram
ATI Radeon 9000 128MB

I had HyperThreading disabled in my BIOS and I was getting basically the same symptoms described by 5150 users. After reading emanuele's post, I remembered that I had HT disabled, so I enabled it and Knoppix boots easily now.

I don't know what control you have over CPU hyperthreading in your BIOS, but on my comp:
HT disabled = Knoppix won't boot
HT enabled = Knoppix boots

Note: Since I installed Windows XP with HT disabled, if I change this setting in the BIOS I would have to reinstall XP. But I am happy that I know how to get Knoppix working now.


10-07-2003, 12:15 AM
I don't know what control you have over CPU hyperthreading in your BIOS, but on my comp:
HT disabled = Knoppix won't boot
HT enabled = Knoppix boots

This is very interesting...

Unfortunately we Dell Inspiron 5150 owners don't have the possibility to turn HT on, since Dell BIOS (what a piece of crap, bleah! :evil:) don't permit to turn it on, as far as BIOS version A24, which is the latest currently available to my knoledge.

Anyway your observations are consistent with the fact that on 5150s HT is off by default (and locked to that position.)

It remains to see if the Dell BIOS is so buggy to not permit to boot SMP enabled kernels even if one could hypothetically turn HT on...


10-07-2003, 12:39 AM
I've just read that HT is not activable on early 5150s (like mine) not because of the BIOS, but because Dell shipped them with a "crippled" 3.06 GHz P4 CPU that had HT disabled at the hardware level.

Dell is now shipping new 3.06 GHz P4s with HT.

If you have an A24 BIOS installed and you don't see a menu to turn HT on, it means that you have an old crippled 3.06 GHz P4 (like me :-(

For more info see here:
and/or the Inspiron/BIOS forum on dell.com:

I think I'll never buy a Dell again in my life...