PDA

View Full Version : Knoppix (Debian) pppoeconf and cable modem



guest
11-29-2002, 11:38 AM
When i try to use pppoeconf to configure my cable modem I get a message saying that my another program is using my modem already???

I am with Cable Wanadoo in the Netherlands. My modem is a COM 21.

I also have a dual boot system using Windoze. The modem functions ok in windows.

Any Ideas???

Further info:

I recently installed Windows and reconfigured the network. I heard a rumour that Windows leaves the Modem turned on even when you are not connected to the internet. I think that it may be the source of the pppoe service operating error message. i have a dual boot system. I'm still not brave enough to try Linux only! Soon I hope!

This info is from the Cable Modem How-To:

The current Wanadoo cable modems operate via the serial port, acting like normal modems, answering AT commands like phone modems. The setup is really very easy, because all the chat script needs to do is dial ATDT4. (this is in ppp-on-dialer). Hence it uses PPP, which is unusual for most cable modems.

Relevant files are included /etc/ppp/ppp-on

DIALER_SCRIPT=/etc/ppp/ppp-on-dialer
exec /usr/sbin/pppd -detach /dev/ttyS0 115200 connect $DIALER_SCRIPT &


/etc/ppp/ppp-on-dialer

exec /usr/sbin/chat -e '' AT '' ATDT4


/etc/ppp/ppp-off

#!/bin/sh
################################################## ####################
#
# Determine the device to be terminated.
#

sleep 5

if [ "$1" = "" ]; then
DEVICE=ppp0
else
DEVICE=$1
fi
#
################################################## ####################
#
# If the ppp0 pid file is present then the program is running. Stop it.
if [ -r /var/run/$DEVICE.pid ]; then
kill -INT `cat /var/run/$DEVICE.pid`
#
# If the kill did not work then there is no process running for this
# pid. It may also mean that the lock file will be left. You may wish
# to delete the lock file at the same time.
if [ ! "$?" = "0" ]; then
rm -f /var/run/$DEVICE.pid
echo "ERROR: Removed stale pid file"
exit 1
fi
#
# Success. Let pppd clean up its own junk.
echo "PPP link to $DEVICE terminated."
exit 0
fi
#
# The ppp process is not running for ppp0
echo "ERROR: PPP link is not active on $DEVICE"
exit 1


/etc/ppp/keepalive.sh

#!/bin/sh

# keepalive.sh

# This is a keepalive script for the Casema cable modems. This script was
# lifted from the /usr/doc/HOWTO/unmaintained/mini/Dynamic-IP-Hacks
# document. There should be an entry in your crontab looking like:
# */2 * * * * /etc/ppp/keepalive.sh
# to run this script every 2 minutes to see if your connection is still
# up, if not, gracefully kill the pppd process and remake it.
# Modify paths as necessary.


if [ -f /var/run/ppp0.pid ]; then
ping -c4 -l3 195.96.96.97 2>&1 | grep "0 packets" > /dev/null && \
{ /etc/ppp/ppp-off > /dev/null 2>&1 ; sleep 2 ; /etc/ppp/ppp-on }
else
/etc/ppp/ppp-on
fi


/etc/resolv.conf

search dynip.com
nameserver 195.96.96.97
nameserver 195.96.96.33


/etc/sysconfig/network (this file applies only to RedHat and Mandrake distributions, adapt accordingly for other distributions)

GATEWAYDEV=ppp0
GATEWAY=195.96.96.97


I've documented some things in the files themselves. The ppp-on script is called during boot time from /etc/rc.d/init.d/ppp and the ppp-off script during shutdown. The ppp-on-dialer is called from the ppp-on script. The keepalive script for keeping the connection alive as long as the computer is on (might as well, right?) is called from crontab (see the keepalive file for details). The /etc/sysconfig/network file specifies the default gateway for routing. The resolv.conf tells the computer which IP of casema.net to send DNS queries to (this is pretty standard across all unixes, I believe).

I've forgotten to include the /etc/ppp/pap-secrets which should be the same as the ExpressNet, Maryland, Maryland. There's also the question of the ip-up, ip-down. These however, didn't need to be changed. I've also included the options.ttyS0 file, which should be in /etc/ppp/ppp-on. It is read by the pppd daemon as it logs on. There are a couple options like defaultrouteadd that should be on. ttyS0 is the port where you install your modem mine is on COM1 == ttyS0. Change accordingly.

/etc/ppp/options.ttyS0

asyncmap 0
crtscts
defaultroute
lock
modem
name cvd




Incidentally Wanadoo recomends Roaring Penguins pppoe program.

Thanks.

12-22-2002, 11:48 PM
--------------------------------------------------------------------------------
What does it mean when you see the message eth0 backgrounding?


In Windows 98 my ethernet is set up like so:

RealTek 8139 Series PCI NIC
IP 169.254.75.54
Subnet: 255.255.0.0
DHCP Server: 255.255.255.255

NTS PPPoE Adapter

When I connect the ISP assigns an IP Address, a Subnet mask and a default gateway.


What does this mean and how do I make it happen in Linux? After reading a news item on www.oss.net today I find myself more eager to move away from Microsoft for security reasons.

Knoppix correctly identifies the eth0 card but .......backgrounding? :?:




_________________
Women and cats will do whatever they please and men and dogs may as well relax and get used to it. Robert Heinlein

12-22-2002, 11:50 PM
I am trying with two different flavours of linux in the quest to connect:

Knoppix which is basically Debian Woody. It uses Etherconf for the eth0 configuration.

or

SUSE 8.1

My preference is to get Knoppix running but I'll be happy with any linux. The really wierd thing is I had the internet running no problem with both until I had to reinstall Windoze after I got a strange virus. I thought I just used DHCP and then used Roaring penguin's rp-pppoe to connect. Doesn't work now though

I have a cable modem COM21. A Dutch guy has a site showing how to connect to my ISP Wanadoo.nl (in Dutch). http://double-l/johan/lwanadoo.html The screenshots are clear and the rp-pppoe works as shown as advertised. I 'm sure I am missing something really obvious in setting up my eth0.

12-23-2002, 12:14 AM
http://www.cs.helsinki.fi/u/hendry/content/hoasnet/

Maybe this page can help

FelixDzerzhinsky
12-23-2002, 11:01 PM
More info about my setup.

COM 21 cable modem. ISP assigns new IP each time.

This from Windows.


Windows 98 IP Configuration

Host Name . . . . . . . . . : HAL9000
DNS Servers . . . . . . . . : 195.96.96.97
195.96.96.33
Node Type . . . . . . . . . : Broadcast
NetBIOS Scope ID. . . . . . :
IP Routing Enabled. . . . . : No
WINS Proxy Enabled. . . . . : No
NetBIOS Resolution Uses DNS : No

Ethernet adapter :

Description . . . . . . . . : PPP Adapter.
Physical Address. . . . . . : 44-45-53-54-00-00
DHCP Enabled. . . . . . . . : Yes
IP Address. . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . :
DHCP Server . . . . . . . . : 255.255.255.255
Primary WINS Server . . . . :
Secondary WINS Server . . . :
Lease Obtained. . . . . . . :
Lease Expires . . . . . . . :

Ethernet adapter :

Description . . . . . . . . : NTS PPPoE Adapter
Physical Address. . . . . . : 44-45-53-54-77-77
DHCP Enabled. . . . . . . . : Yes
IP Address. . . . . . . . . : 62.234.102.218
Subnet Mask . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . : 62.234.102.218
DHCP Server . . . . . . . . : 255.255.255.255
Primary WINS Server . . . . :
Secondary WINS Server . . . :
Lease Obtained. . . . . . . : 01 01 80 00:00:00
Lease Expires . . . . . . . : 01 01 80 00:00:00

Ethernet adapter :

Description . . . . . . . . : Realtek 8139-series PCI NIC
Physical Address. . . . . . : 00-50-BF-5C-D0-89
DHCP Enabled. . . . . . . . : Yes
IP Address. . . . . . . . . : 169.254.75.54
Subnet Mask . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . :
DHCP Server . . . . . . . . : 255.255.255.255
Primary WINS Server . . . . :
Secondary WINS Server . . . :
Lease Obtained. . . . . . . : 12 23 02 22:16:52
Lease Expires . . . . . . . :

Any ideas on how to translate this to knoppix?

Thanks for those who have replied.

FelixDzerzhinsky
12-25-2002, 10:07 PM
Can Windows affect a dhcp cable modem on a dual boot system?

I used to have SUSE and Knoppix functioning fine on a dual boot system with Win 98. Then I had a virus in Win 98 despite having anti-virus software. I had to reinstall Win 98 and then reinstalled linux. Since then I can get on the net with Win 98 and not with linux. I have a COM 21 Modem and my ISP is Cable Wanadoo in the Netherlands.

There is info about the Cable Wanadoo connection in Dutch here:

http://double-l.nl/johan/lwanadoo.html

My ethernet card configuration in Win 98 is shown above.

Any thoughts how to make it go in knoppix?

I've tried DHCP and static IPs. When I try to use pppoeconf it says I another pppoe process. How can I check for this and shut killall pppoe processes in knoppix?

I tried killall pump and got "no process killed" back as reply?

More info in heading "Network Card" (on linux-tag fuorum) and at thei url:

http://www.linuxformat.co.uk/modules.php?op=modload&name=phpBB_14&am p;file=index&action=viewtopic&topic=2829&forum=1&11

Thanks for those who have tried already!

FelixDzerzhinsky
12-30-2002, 05:52 AM
Problem solved partially. I am now on the net using knoppix but I must do the following:

#su
#password
#mii-tools
reply is :

eth0: 100mbit half-duplex no-link

so then I

mii-tool -F 10baseT-HD eth0

pppoeconf as normal.

eth0 is configured static similar to my win98 setup in winipcfg but with nothing in default gateway.

My problem now is I have to be in su mode to log on. How do I change the pppoe permission so that all users can log on?

And is there a way to keep the eth0 in 10 half-duplex all the time? So I don't (or more importantly my girlfreind) doesn't have to keep typing these commands?