View Full Version : Can't diallup anymore

10-23-2003, 02:44 AM
I'm pretty sure I made some horrible configuration error at some point while upgrading.

Symptoms are as follows:

Modem worked fine with pon and poff before upgrade

Modem works fine with SuSE 8.1

I've re-run pppconfig with no good result

The modem's lights just sort of fibrillate

There's a pile of stuff about trying to load isdn modules on start up (I have plain old diallup, no ISDN)

Any ideas welcolmed. I don't really have an idea as to what I ought to be looking for, let alone how to fix it. And I really don't want to re-install. :-(

If anyone wants any details, just tell me.

10-23-2003, 01:51 PM
Oh God, is it really that bad?

10-23-2003, 03:23 PM
Yes it's really that bad ....

Sorry, I thought I posted last night...

If you aren't using isdn and don't plan on using isdn in the near future why not remove all isdn packages?

do a:

dpkg -l | grep isdn

and apt-get remove --purge

the isdn packages.

What must have happened in your upgrade is a new package was allowed to use its new config file instead of using the old ones on your system (just my guess)

FYI: I use wvdial for my dialup it works better than anything else I've tried



10-23-2003, 08:09 PM
Thanks Rock -- I'll try that and see what happens.

Any ideas what I actually need to run a straightforward diallup? Have pon and poff (which I rather like now I've iconised them) but do I need anything else?

10-24-2003, 03:20 AM
OK, I purged everything with ISDN on it and now the error messages have stopped. But I still can't pon and poff.

Anyone any ideas as to what debs underly the dialup connection process? pppd does run, but dies after no connection is made. The modem still fibrilates. What config files should I be looking at?

10-24-2003, 04:31 AM
it should be in the following packages:

ppp and pppconfig

run plog as root and see what it gives as output


10-25-2003, 12:36 AM
Here we go (not all that revealing, to me, at any rate):

root@molehole:/home/john# plog
Oct 24 19:40:41 molehole chat[626]: -- got it
Oct 24 19:40:41 molehole chat[626]: send (ATDT179^M)
Oct 24 19:40:41 molehole chat[626]: expect (CONNECT)
Oct 24 19:40:41 molehole chat[626]: ^M
Oct 24 19:40:41 molehole chat[626]: warning: read() on stdin returned 0
Oct 24 19:40:41 molehole chat[626]: Failed
Oct 24 19:40:42 molehole pppd[625]: Connect script failed
Oct 24 19:40:43 molehole pppd[625]: Exit.

But you should see the problems I'm having with a fresh install of SuSE 8.2!

I'll be away for a bit so please don't interpret a lack of reply as ignorance!