PDA

View Full Version : X problem with Knoppix 20-1-2003



TheStar
01-29-2003, 06:05 AM
When using Knoppix 20-1-2003, currently on a sis-based motherboard,
I have been unable to get X working.
The splash screen comes up.
But XFree86 refuses to work - not even when I run XFree86 -configure
Not in vga=normal
XFree86 tries to use the vesa drivers - and when that fails, it tries to use
the fbdev drivers - they both fail. When it fails - it just fails
(No garbled screen, etc, just back to the console)

The console, however, appears to work in fb mode, so I suspect that it
is an XFree86 problem.

When I use an older knoppix version (can't remember which, late last year) - it was still 3.1, and uses the same XFree86 version (4.2.x), it
works flawlessly, booting into KDE, etc.


What I'd like to know is, has anyone else had any problems?

hammy
02-10-2003, 01:26 AM
I too have had problems with video on a SiS based motherboard. When I first start I had to use the cheat "knoppix vga=normal" to get to the autodetect phase. I got a "modprobe: can't locate module server: XF86_SVGA" during the autodect. When the install starts, I loss video getting an "VGA not supported" error. I tried all the other cheat I fould here and nothing works. If anyone has any idea's how to fix this, let me know as I am new to Linux.