PDA

View Full Version : ACER TM250: Can not boot



rms46
10-28-2003, 08:08 AM
Hi,

I tried Debian Woody as well as Knoppix 3.3 at a ACER TM250 (15", 2.4 GHz P4) with no luck :cry:
Both boot will stop after this message:


Loading root.bin...
Loading linux.bin... ready.
Uncompressing Linux... Ok, booting the kernel.


Then it freeze...

BTW,
:arrow: The only linux that works is Mandrake 9.1 that is provided by ACER (no install, restore only)
:arrow: Knoppix 3.3 works fine on ACER TM660 (Centrino 1.4 GHz).

regards,

bogdanb
10-28-2003, 11:28 PM
I just tried Knoppix on an Acer TravelMate 240 and got the same results: it freezes after booting the kernel. I tried fb1024, textmode and expet boot options, the results are the same.

Any suggestions?

bogdanb
10-28-2003, 11:41 PM
This is strange, since TravelMate240 is listed as Linux-compatible on one of the other threads. It says there Acer actually released a TM240 model with Linux preinstalled (in asia, I think).

bogdanb
10-29-2003, 12:40 AM
To recap: I tried Knoppix on a TravelMate 240 and it freezes just after it says 'booting the kernel'. If I use boot options (I think the kernel matters here) that keep the laptop in text-mode, the text remains on the screen, otherwise the screen goes blank. Any disk activity ceases. It does not respond to any keyboard input I tried. The network led keeps blinking, but as far as I can tell it always does on this laptop (even with no network activity). I have tried all kernel versions - frambuffer, expert, the one with no hw detection, all of the no* options, to no avail. Since the kernel doesn't boot, testcd doesn't work.

There is a report (on http://www.geocities.com/ma_sivakumar/acer_linux_laptop.html ) that Acer launched a Linux-preinstalled laptop for the Indian market. Also, I just tried booting the Gentoo Linux LiveInstall CD and it boots just fine. It seems to go through hardware-detection alright (though I didn't look very carefully at what it finds), the graphical console works and I could connect to the internet just right. This means there shouldn't be anything intrinsic to linux.

I don't want to actually install Gentoo, though, since the laptop has some sort of hidden 'repair' partition or something (it came with windowsXP Home), and I don't want (nor have time) to mess with it yet. I'm also not very experienced with Linux (though I do compile a kernel now and then) and even less so with laptops; this one is not even mine, it's my father's.

I tried Gnoppix, it didn't work either. However, I'm not sure if that CD isn't broken. I'll check it later.

Anyways, it would be nice if anyone with actual experience with Linux could look at a travelmate (come one, one of you guys must have a friend who owns one), find out what the problem is and 'fix' knoppix. Please!!!

knoppixuser42
10-29-2003, 11:43 AM
Just to state that my TM 234 LC needs this boot option 'noapic' to work.
However my problems was not crashing, but 'only' lack og network, usb and sound until I tried 'noapic'.

Good luck,
Claus

rms46
10-30-2003, 05:37 AM
Well, I found some APIC related URLs from http://www.knoppix.net/forum/viewtopic.php?t=2833:
:arrow: https://listman.redhat.com/archives/anaconda-devel-list/2003-February/msg00082.html
:arrow: http://www.redhat.com/archives/anaconda-devel-list/2003-February/msg00050.html

I will let you know if it works...

rms46
10-30-2003, 09:56 AM
:evil: I tried every "no" option including failsave with no luck...
Well, the conclusion is:

ACER TM250 (CPU P4 2.6 GHz, RAM 512 MB)
Knoppix 3.3: Failed
Debian 3.0: Failed
Mandrake 9.1: Failed

Slackware 9.0: OK
Redhat 9.0: OK
Mandrake (restore CDROM for ACER 250): OK

ACER TM661: (CPU Centrino 1.4 GHz, RAM 512 MB)
Knoppix 3.3: OK
Debian 3.0: OK

Muto
11-01-2003, 01:02 PM
Having the same problems here(TM 242), i can add some other information:

- there is a report (linked from tuxmobil.de) http://www.blue-screen.at/index.php?site=docs/linux/acer, from someone who managed to install debian (german only). Basically it follows the idea to install an older, working version and update to a newer one.
An older Debian (kernel 2.2) works fine, showed a quick test. Inspired by this i tried an older version (Knoppix 2.2), but it freezes and screen remains black...

Just to mention:
- FreeBSD runs perfect :P

rms46
11-06-2003, 10:58 AM
Basically it follows the idea to install an older, working version and update to a newer one.

May I know how to update Knoppix?
Burn a new CDROM? :lol: :lol: :lol: :lol: :lol:

Anyway, I keep some information about Slackware and Redhat configuration at
http://rms46.vlsm.org/1/95.html.

regards,

RMS46.

joeyk
06-04-2004, 03:04 PM
Acer TravelMate 240 (TM 240) works fine with Knoppix 3.4 and Kernel 2.6. Just type 'knoppix26' when it says 'boot:'

jamborm
06-16-2004, 08:06 PM
Acer TravelMate 240 (TM 240) works fine with Knoppix 3.4 and Kernel 2.6. Just type 'knoppix26' when it says 'boot:'

I have Acer Travelmate 244LM and Knoppix 3.4 (I just have downloaded it) and whenever I try to boot with the knoppix26, the computer freezes during the 'autoconfiguration of devices.' That is still a big progress since the 3.3 didn't even really start booting :-)

I have no problems running Debian with 2.4 kernel though. The only thing you have to do is to compile kernel without any APIC support, not even as a module since the noapic boot option makes no difference (ie it still hangs).