View Full Version : Wont boot on Toshiba Portege 3480ct

10-31-2003, 01:01 AM
I am trying to get Knoppix to boot but it keeps hanging after it detects my processor (Petium III Coppermine 600MHz, 256 kb cache) It detects the APM bios and I have tried "knoppix noapm" and it still hangs. I also tried "knoppix failsafe" and have the same issue. Any advice? I would really love to get it running on my laptop.
Thx :evil:

10-31-2003, 10:27 AM
Two suggestions, based on the idea that Knoppix post 2003-06-06 does not recognise the MBR on a hard disk.

a) Register for Knoppix Bugzilla and vote for bug 246

b) Try using Knoppix 3.2 dated 2003-06-06 (or earlier) and you may be able to boot to Knoppix

The HD partition recognition routines changed in June, but I've not been able to check them out, due to other hassles. Knoppix otherwise (scream) seems to work fine on Toshiba machines.

Good luck



02-17-2005, 06:09 PM

Don't know if you got anywhere with your 3480CT but I have EXACTLY the same symptoms (and tried exactly the same solutions as you) on a 3490CT. I also tried the 3.2 MiB version of Knoppix with exactly the same result.

If you got anywhere on this one, perhaps you can help me since these machines are almost identical (including the drivers) !! :wink:


02-22-2005, 03:06 AM
I got this to work on a 3490CT as follows:

- Enter bios on startup by pressing "Esc" key whilst the Toshiba startup window is still displayed (in red letters)
- Once in bios, PgDn key to get to page 2/2
- In the right column of page 2 go to PC Card section
- Change Controller mode from default (auto) to "PCIC Compatible"

This should solve the problem if, like me, you are using the Toshiba port replicator CD drive.


02-22-2005, 04:03 AM
Pardon me for being dense, but why does MBR detection have anything to do with knoppix freezing during boot? AFAIK you can boot knoppix with no HDD installed at all, much less an MBR. I regularly boot knoppix to perform HDD installs on drives that have been zero-filled from start to finish. No problems. Just seems like a misleading answer to the question...