View Full Version : X-server error with Knoppix 3.3 on a Toshiba 2550CDT

11-02-2003, 12:18 PM
I have been using knoppix-3.1 and 3.2 with no problem at all on this Toshiba 2550, but now Knoppix 3.3 throws a "no suitable X-server found" error.

The hardware is detected correctly:
Video is Cyber 925 (generic) Cyber 925, using Xfree86 (trident) server
Monitor is TOS5081 H28.0-96KHz, V:50.0-62.0KHz

The server XFree86 (trident) fails, and knoppix retries with the server XFree86(vesa) and XFree86(fbdev) but fails too, with the final error message :
Error: no suitable X-server found

The system works then fine in single user mode (text mode).

I found the following message in /var/log/XFree86.0.log:

(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.6
(EE) open /dev/fb0: No such device
(EE) No devices detected.
Fatal server error:
no screens found

This "open /dev/fb0: No such device" message seems like a bug?
Any clue?

Pierre Maitre

11-02-2003, 04:18 PM
Happens a lot with laptops and some exotic vga chipsets...

Try the one of the screen optionsfrom the cheatcodelist .
( http://www.knoppix.net/docs/index.php/CheatCodes )

In your case try :

knoppix xmodule=fbdev knoppix xserver=XFree86 fb1024x768

Hope this'll get you on track ;-) .


11-03-2003, 03:13 PM
> In your case try :
> knoppix xmodule=fbdev knoppix xserver=XFree86 fb1024x768

For my machine, the correct syntax would be
knoppix xserver=XFree86 xmodule=fbdev fb800x600

I had tried already many cheatcodes of the same kind, including this one, but I alway get the same error. The puzzling fact is that it worked without a glitch in the previons versions of knoppix (3.1 and 3.2). And also the fact that the chipset is recognized correctly...

Any other idea?

11-04-2003, 04:53 PM
acpi issues (settings in bios)