View Full Version : No root file system (but system works)

01-31-2003, 04:02 AM

I've just done a knx-hdinstall on a Dell Inspiron 4000, and I haven't had much trouble. Most everything works. However, I've been attempting to install a newer kernel, because I want to add the preemptive multitasking kernel patch, and I've noticed something very odd.

mount reports three filesystems: proc, devpts, and usbdevfs. There's no root filesystem, even though there obviously is, as the system works beautifully. The new kernel kernel panics with root filesystem problems, but the original knoppix kernel works fine.

Now, I've also noticed that every time I reboot it mounts proc again, so I get multiple lines in mount of none on /proc type proc (rw).

I've tried mounting /dev/hda5 which is the linux partition, I've tried removing proc and remounting remount,ro /dev/hda5, and all sorts of other things, but nothing works. I mounted /dev/hda5 in /mnt/hda5 (recursive? nah...) and chrooted into it, and got a good / and when I exited was able to umount /proc, which was interesting...not having anything appear when you type mount...=)

Running lilo, using initrd, used make oldconfig and make-kpkg to make the new kernel (from apt-get kernel-source-2.4.20). I think that's all.

Any ideas?


01-31-2003, 09:21 AM
What date-release of 3.1 are you using? IIRC only the latest or latest two date-releases have mtab fixed so it is "proper" or somewhat proper on a hd install. I think I'm now running 1/1/2003 on my hard drive and the df output is a little goofed up but usable. On my November date-release install I linked /etc/mtab to /proc/mounts and at least was able to see the root filesystem with df. You might look into the FAQ regarding df.