View Full Version : HDD iso image install method doesn't work

11-12-2003, 05:17 AM
I tried the method detailed at:


It didn't work.

Here is what I did:

None of the linux mini distros can see my usb cd-rom, and I can't boot from it, so I copied the knoppix iso to a cf card and mounted it with the parted-usb distro. I created partitions 1, 2 and 3 on my /dev/hda. /dev/hda1 is ext2, 64mb. /dev/hda2 is linux swap, 192 mb. /dev/hda3 is about 3.5gb ext3.

I copied the iso to the hda3 partition, and mounted it with the loopback device. After copying the files into hda3, I rebooted with the knoppix boot.img floppy, and attempted to boot knoppix by entering:

knoppix home=/dev/hda3

after the usual messages knoppix dumped me in the lame rescue shell, telling me that it had failed to find the knoppix partition. I tried mounting hda3 in the rescue shell, only to get an error message referring to some modules that failed to load. The ext2 hda1 partition mounted just fine though.

Is there a problem booting knoppix from an ext3 file system?

12-02-2003, 03:16 PM
Just to be clear, you've got an ISO file on /dev/hda3. You mounted the ISO as a loopback device and then copied the "/KNOPPIX" directory from the ISO onto /dev/hda3?

You really only need /KNOPPIX on /dev/hda3 in order to boot, but you don't need to specify "home=/dev/hda3" as the boot process should detect the files there.