View Full Version : USB cruzer mini thumb drive

11-13-2003, 04:59 AM
Hey...Knoppix is cool! Been exploring and very impressed.

Running on a Compaq Presario 705 with no probs - except booting with mini thumb attached. Can boot without attached as reported elsewhere and can mount drive after booting and then plugging in device and running mount in root shell.

Question: Any chance this might get fixed anytime soon? Would be cool to have a persisent home directory on a thumb drive.

Also, don't know if this might be an the problem, but the device is USB 2.0 but the Compaq is USB 1.1. Works under windoze and works on Knoppix as long as automount is disabled.

Keep up the great work...very cool stuff!

11-13-2003, 03:57 PM
I am having a similar problem with the SanDisk cruzer mini 256MB USB 2.0 flash drive.

Knoppix 3.3 (both 9/24 and 11/3) hangs during boot with the flash drive plugged in. I've tried this on multiple boxes, 2 laptops and 2 desktops, USB1.1 and USB2.0.

Additionally, if I plug in the flash drive after booting up, the Knoppix wedges after a minuite or so.

I've successfully used this particular flash drive on RedHat 9, and under Win2k.

I too would LOVE to travel with only a Knoppix cd and this flash drive.

Any suggestions?

12-22-2003, 06:14 PM
I just got the device yesterday, and found that it was recognized and working under RH 7.3 and Debian 3.0 (and for what it's worth, it worked fine with the Win98SE, WinME and Win2K boots I keep around for testing as well).

However, I noticed under Linux that the device comes from the factory formatted as FAT12. I played around a little and found that I could partition the device into multiple partitions (Ext2, NTFS and FAT32), and formatted as such. The only problem I found is that Win2K server only recognizes one FAT32 (or NTFS) partition on the device (WinMe recognized multiple FAT32 partitions), but Linux had no problem with any of them. I haven't played with any other partition types, yet.

Short story... you may try repartioning and formatting the device as Ext2 for example, first (perhaps Knoppix has trouble with FAT12 on the device?). In the end, I created one Ext2 partition for Linux use, and a small FAT32 parition for "fluff" I may need to collect from Win clients I service.


12-26-2003, 09:19 AM
I've found that unpartitioned keys can be an issue, try partitioning into 2 or more partitions (fat is fine) with the drive vendor utilities and see what happens.

01-08-2004, 10:48 PM
Sandisk Cruzer Mini 128 MB usb stick notes:

I was eventually successful getting Sandisk Cruzer Mini 128 MB usb stick to work with Knoppix.
At best, it usually boots up and ignores the usb stick if it's inserted.
At worst, I get the hard system hangup problems upon re-inserting it.
Now, I can make it work reliably, but I have to do the following exactly.
(I'm using a Dell GX270 with ATI ultra 128 Mb graphics card at the moment.)

Recipe: (it's not a script, but my comments are marked by #'s)

knoppix xmodule=ati screen=1600x1200 (my graphics card is not autodetected)
#allow knoppix to boot fully
modprobe usb-storage
mkdir /mnt/sda1
# add next line to /etc/fstab
/dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0
# insert usb stick
# Wait for SCSI messages followed by "Write protect off"
# Remove & reinsert; seems to be needed ... this should be okay since device hasn't been mounted yet
# Then don't delay too long before typing mount command
<Enter> # to get prompt
mount /dev/sda1
# if usb led is blinking, this is good, Knoppix is accessing it.
# If it's not blinking, it may hang.
# Before removing USB stick, unmount the file system
umount /mnt/sda1


While I was struggling to find a recipe which would be reliable,
I had read some suggestions about multiple partitions, so
I repartitioned it for just one primary DOS partition.
It's not exactly the same as it was out of package.
I don't know it this made any difference, but this is what I had done.
(I wrote this part down while I still remembered it, before find the above recipe.)
I would first try the above recipe without repartitioning or reformatting.

Original size was 123 MB

Reformatted with W2K for FAT, 123 MB
Reformatted with W2K for NTFS, 122 MB
Reformatted with W2K for FAT, 123 MB

Repartitioned using Disk Management in W2K; reformatted 2K blocks (auto), 117MB

#Crappy tool. I couldn't adjust how much of the drive was being used in the partition.
#What's more, all my usual partitioning utilities were forbidden to directly access any disk under w2k

Repartitioned using FDISK in W98, 96% --> 100%, reformatted 2K blocks (auto), 122.9 MB, 128,688,128 bytes


This USB stick worked out of box for Dynebolic 1.1 live CD without any finagling,repartitioning needed.


Is there something about the original Cruzer format needing to be PC&MAC readible that makes it unexpected for Knoppix auto filesystem mounting routines?


03-01-2004, 04:41 AM

Tried everything you said, but still doesn't work. I'm new to all this, so maybe i'm doing something wrong. Could you go into more detail about adding lines to fstab? Maybe that's my problem.


03-05-2004, 07:21 PM
Things have gotten easier with Knoppix_V3.3-2004-02-16-en
with a SanDisk 128 Mb stick on a Dell Optiplex GX240. All the above is not needed anymore, thanks to whomever tweaked the recognition & mounting routines. Whew!

Boot from CD _without_ USB stick inserted. (It hangs if I forget and leave the USB stick already in there).

Wait until the KDE desktop appears and all is ready.

Then insert the USB stick into one of the rear USB ports.
(For some reason the convenient front ports don't always work for me and sometimes state the USB device is refusing to accept a new address.)

Wait a few moments and everything is now done automatically, and a little icon should appear on the desktop for "Hard Disk Partition [sda1]".

It works just like the other hard disk icons, which are read only by default. If you want it Read/Write, before opening it, you should right click the new icon, choose Device tab, and uncheck the read-only box. If you've already opened it, you may have to right click the icon and choose unmount.

Good luck


03-20-2004, 02:14 AM
I'm having the same lockup problem when I insert my sandisk cruzer mini 256MB. The strange thing is that is worked out of the box the first time I used it with Knoppix. I had this crazy idea that I'd make a boot disk out of it and tried dd if=/KNOPPIX/boot.img of=/dev/sda/. The boot image installed just fine. After that Knoppix didn't see the device and my systems wouldn't boot off it either. I could view the boot image files in WinXP, but the capacity was all wrong, so I reformatted it in WinXP. Now it no longer works in Knoppix. I tried the recipe posted by pbs, but that didn't work, still locking up. It works fine in WinXP.
Was some data lost on the cruzer when I formatted it?

I'm using Knoppix 3.3, 2-16-2004 beta.

03-23-2004, 02:57 AM

It comes out slightly differently when reformatting &/or partitioning under different OSes (see above).
Perhaps you can experiment with FDISK from different bootdisks.

Only those who took meticulous notes from step zero will know if it then matches the out of box configuration exactly. :( But at after formatting from win98, the 123 MB capacity agreed within round off error at the various reported precisions. Moreover, the stick could be used from Knoppix 3.3 2-16-04 as long as it was plugged in AFTER booting and KDE coming up. After that it was good enough, so I quit messing around.

As for booting, I saw
but haven't tried it since my bios doesn't support USB booting.
Notice very end discussion of boot sector on that page.

Or try using dd to copy the boot sector from a windows emegency bootdisk prior to XP.


04-09-2004, 03:34 AM