View Full Version : External Motorola ModemSurfer 28.8

02-01-2003, 06:09 PM
:cry: We are working to DEMO Knoppix 3.1 for our computerclub.
Knoppix doesn't have the option for Com port 5 which is where our
56K PCI US Robotics sets up.
We when for a (read Quick) Motorola ModemSurfer 28.8
external, which works fine on Win98.

Kppp doesn't seem to get the "OK" responce back form the Modem and hangs.
Have tried two different strings AT&F and AT (a AT is what WIN 98 uses)

My deadline is feb.7,2003- midnight cst.-USA.

Thanks in advance,


02-02-2003, 03:46 PM
Your external modem "should" either be at /dev/ttyS0 (COM1) or /dev/ttyS1 (COM2). kppp is probably using /dev/modem.

Try to set up kppp with /dev/ttyS1 as your modem and see if it works, if it does OK if not try /dev/ttyS0 as your modem device.



02-03-2003, 12:30 AM
8)I am on Com1/tty0. Using:Xon Xoff. Cr & Lf.
KPPP says modem ready, modem initalizing. Debug log window(at the bottem) says Expecting OK.

the is no responce from the modem. ???

I'm now using ATE1V1 to turn on the echo, but still on feed back and still hangs.! :(

Hereis the Win98 log for the modem:

02-02-2003 16:27:53.01 - Standard Modem in use.
02-02-2003 16:27:53.01 - Modem type: Standard Modem
02-02-2003 16:27:53.01 - Modem inf path: MDMGEN.INF
02-02-2003 16:27:53.01 - Modem inf section: Gen
02-02-2003 16:27:53.28 - 115200,N,8,1
02-02-2003 16:27:53.50 - 57600,N,8,1
02-02-2003 16:27:53.50 - Initializing modem.
02-02-2003 16:27:53.50 - Send: AT<cr>
02-02-2003 16:27:53.50 - Recv: AT<cr>
02-02-2003 16:27:53.60 - Recv: <cr><lf>OK<cr><lf>
02-02-2003 16:27:53.60 - Interpreted response: Ok
02-02-2003 16:27:53.60 - Send: ATE0V1<cr>
02-02-2003 16:27:53.61 - Recv: ATE0V1<cr>
02-02-2003 16:27:53.71 - Recv: <cr><lf>OK<cr><lf>
02-02-2003 16:27:53.71 - Interpreted response: Ok
02-02-2003 16:27:53.71 - Send: ATX4<cr>
02-02-2003 16:27:53.81 - Recv: <cr><lf>OK<cr><lf>
02-02-2003 16:27:53.81 - Interpreted response: Ok
02-02-2003 16:27:53.81 - Dialing.
02-02-2003 16:27:53.81 - Send: ATDT#######<cr>
02-02-2003 16:28:16.30 - Recv: <cr>
02-02-2003 16:28:16.30 - Interpreted response: Informative
02-02-2003 16:28:16.30 - Recv: <lf>
02-02-2003 16:28:16.30 - Interpreted response: Informative
02-02-2003 16:28:16.31 - Recv: CONNECT 57600
02-02-2003 16:28:16.31 - Interpreted response: Connect
02-02-2003 16:28:16.31 - Connection established at 57600bps.
02-02-2003 16:28:16.31 - Error-control off or unknown.
02-02-2003 16:28:16.31 - Data compression off or unknown.
02-02-2003 16:28:16.46 - 57600,N,8,1
02-02-2003 16:28:21.16 - Hanging up the modem.
02-02-2003 16:28:21.16 - Hardware hangup by lowering DTR [/quote]

02-03-2003, 06:03 AM

I am on Com1/tty0
Are you using /dev/tty0 or /dev/ttyS0?

BTW I haven't used kppp for quite a while (years), so I don't remember the settings etc. I normally use setserial and minicom to play with modems because they are standard linux (*nix) tools, you shouldn't really need to use any special modem init scripts with linux. If your pci modem is a hardware pci modem you could get it to work in linux. My Dad's computer has a modem that uses /dev/ttyS4, I had to make the device and then tell kppp to use it, and it works fine.


02-05-2003, 12:58 AM
Are you using /dev/tty0 or /dev/ttyS0?

:) If I could type and chew gum-- (com1) ttys0.

Minicom gave me some more help. Thanks for the info.
As a newbie I"ll have to dig into setserial. This just might do
it. ??
thanks for the help!

02-07-2003, 06:45 AM
Hey verlwb, hope you haven't given up,

I just was given an old motheboard and popped in a processor, memory, vid card, stuck a modem in and booted to knoppix 1-1-2003 and sure enough--I couldn't get kppp or pppconfig and pon to work. Something is goofed up!

So attempt 2, after crashing out (only have 48MB ram and no swap) and rebooting I set up kppp again, ... and again no go so I looked in /etc/init.d and sure enough there is a ppp entry so from a command line (as root) I entered:

/etc/init.d/ppp start

Then I tried to reconnect with kppp and it worked!