View Full Version : Samba script not working after HD install of v3.3

r00t 4orce
11-28-2003, 03:51 PM
Hello all
I just finished a HD install of Knoppix v3.3 2003-11-19 and everything was going great until I tried to use the "Start Samba Server" script under the Knoppix menu. After selecting the script I get a message box for my root PW and I entered that but the message boxes that should follow, what drive(s) do I want to share etc., never appear and running NMAP on shows that Samba is not running.
Does anyone know why this doesn't work? and if there are any fixes or workarounds?

Thanks all...


11-28-2003, 04:07 PM
remove all international language support, except English

Install localepurge

r00t 4orce
11-28-2003, 04:30 PM
this will correct my Samba issue?
can you give me a little more info on "How to remove all international language support"?


12-09-2003, 08:43 PM
remove all international language support, except English

Install localepurge

mmmmmmmmm, are you sure about thats the problem?

12-09-2003, 10:13 PM
this will correct my Samba issue?
can you give me a little more info on "How to remove all international language support"?

No it will not it will just remove the excess locales installed on the system. If you install localepurge you will also want localeconf to actually configure the language you want the system to use and you should check in the file /etc/locale.gen to make sure the Knoppix defaults are not still there otherwise the locales will be regenerated, just delete the locales that you did not keep. If you want to get rid if the KDE internationalizations the use dpkg -l | grep kde-i18n and remove the ones you do not want. I know nothing about samba but this thread (http://www.knoppix.net/forum/viewtopic.php?t=6264&highlight=) should get you starting and stopping it correctly.

r00t 4orce
12-11-2003, 05:46 AM
thanks all -- I'll give the suggestions a try.


12-12-2003, 03:57 AM
It seems strange that you would ask for help on Samba and receive instruction on localepurge! I couldn't get the start Samba script to work either. I found the easiest way to access a networked Windows box was with LinNeighborhood which is on Knoppix under 'Internet'. Here is a reply I received to pretty much the same query on the Linux Format forum.
Confirm that your network settings are correct and working. Open a terminal or DOS box (depending on the machine) and type ping ipaddress.ofthe.other.machine. If one PC can't reach the other, that's your first problem.

Make sure file sharing is installed under Windows. Also make sure that the "Network Authentication" tab below the protocols is set to "Windows Logon" and not "Client for Microsoft Networks" to reduce the level of authentication to something we can work with.

Check your Windows workgroup name and computer name. If necessary, reset these in the Network Connection Wizard (Windows, especially ME is a bit notorious for losing these settings without warning).

Share some folders under Windows. I don't know if ME has the level of authentication that 2K and XP have, where you must add users intending to access shares from another box as users to the sharing box in order for them to be seen. If so, do that.

In Linux, open up /etc/samba/smb.conf as root (or su to root and open it from a terminal, if you know how to do that).

Change the WORKGROUP setting to the same name as under Windows.

Check the other settings in the file to see if anything leaps out at you as needing to be changed, but otherwise add a share to the end of the file by using one of the examples (uncomment it, or copy it and uncomment it, changing the share name and path to reflect your system-- and don't forget, folders can only be shared from your own ${HOME} directory). The general syntax for a Samba share is:

[SHARE_NAME_(no spaces allowed)]
path = /home/username/foldername
comment = what_will_appear_in_the_tooltip/comment
public = yes
guest ok = yes
writable = no

Save any changes, close smb.conf and open /etc/hostname (also as root).

Type your hostname (the name of your Linux box), if it does not appear.

Save and close /etc/hostname, and open /etc/hosts (still as root). Next to " localhost", add your hostname, so that it reads " localhost your_real_hostname". This helps sometimes in making sure that everybody knows that localhost and your_hostname are the same box.

Save and close the text editor, and open your Users and Groups management tool (if you use KDE, that would be KUser, I believe). Add your WinME user and other Linux user as users, using the same usernames and passwords as they have under the other OSes. If you have the option to not create a Home folder for them, you can take it, unless they'll need one for some reason. Save these changes and exit the tool.

Open a terminal, su to root (or log out and log in as root, but really, using the su command is better) and type smbpasswd -a -e username_of_the_ME_user password_of_the_ME_user and hit enter. This will add that user to the smbusers list, which means that Samba won't refuse their connection when they try to access the files shared on your box. Repeat for any other users on the ME or Linux boxes.

Reboot. You could just (re)start the Samba server using the command '/etc/rc.d/init.d/smb stop' and then '/etc/rc.d/init.d/smb start', of course, but I don't know if having a share set will cause the server service to automatically start at boot, and rebooting now is the easiest way to find out. Log in as a regular user. At this point, the ME box should be able to see and access your shares. If not, it means that the Samba server isn't started, so start it with the command above. You may have to wait for the network to refresh to see the shares, which can take up to 15 minutes.

Now, open LinNeighborhood. Go to the Options and set everything how you want it (default mount points, default username/pw, etc). Also, you will want to set "Memorize Shares/Remount on next startup" to active. I usually like to set "ask username/pw once" as well, otherwise it's a PITA. Don't forget to save the new options.

Scan the network and mount the shares you want.

Close LinNeighborhood and open either your Startup folder if using KDE (I believe it's in /home/username/.kde (the dot means it's a hidden folder, so unhide hidden folders if you can't see it)/startup, or the GNOME Control Panel=>Advanced=>Session Manager if using GNOME (sorry I don't know how to create startup shortcuts for other WMs).

In any case, you want to make the following shortcut: LinNeighborhood -m (may need to enter full path to LinNeighborhood, some distros don't recognize it only by name) which tells it to mount the memorized shares without starting the GUI and then exit.

I still haven't managed to connect Linux box to Linux box (Both my systems are dual boot).