View Full Version : LCD Monitors and Knoppix

02-03-2003, 11:11 PM
I have a Fujitsu Siemens LCD 15" model 38B1 and while Xserver is starting the monitor tell "frequency not supported"

My video card is Matrox G400 and it is well recognized during the loading of kernel..
I tried many cheat codes like setting resolution screen and xvrefresh but nothing seems to resolve this problem!

I can't understand why with notebook lcd screens Knoppix is good and with many LCD screen not at all.

I read another post about Sony Flatscreen with similar problems.

Can anyone help me?

Ian Tindale
02-04-2003, 01:39 AM
That's odd. On this machine, it works fine on my similar TFT of the same size. They normally work ononly 60Hz by the way (which is not a disadvantage for LCD tech). In fact, it's the only machine/monitor in the house that Knoppix does work on. If it was down to the other two monitors, I'd have thrown Knoppix in the bin long ago - I'd never have got to see it at all, it only succeeds in shutting down the other monitors.

02-04-2003, 05:58 PM
Exactly the same problem here with a flat screen "IIYAMA AS314UT"!

Whatever I try, it says 'input not supported', even starting with the option vga=normal whiwh should be the standardized output...

However, no problem to have it running on my laptop.

Any idea.?

02-04-2003, 06:47 PM
booting in fail safe worked for me (dell ultrasharp flat-panel).

The only problem with that is now my mouse won't work (dell logitech usb optical wheelmouse)....

any help would be nice... I dont want to boot in failsafe all the time...

02-07-2003, 07:43 AM
I got it working... I used "knoppix xmodule=vesa" and it worked.... It appears my monitor only supports vesa....

02-08-2003, 10:57 PM
I tried xmodule =vesa and other settings like xvrefresh = 60 and both but nothing! My Fujitsu Siemens 38 B1 isn't good for Knoppix :(

Please Can you suggest anything else?


02-08-2003, 11:45 PM
I would get the manual out, or look up online what display modes it supports, and type "knoppix xmodule=XXXX" Where XXXX is the name of the module.

02-09-2003, 12:07 AM
Try "fb 1024x768" (without "knoppix", just fb 1024x768 at boot line) this works with my two LCD monitors

02-09-2003, 12:14 AM
could it be possible than a combination of the two is in order? i.e. a vesa mode only and need the fb option too?

02-09-2003, 05:23 PM
This problem has to de with the differences between CRT-/LCD-monitors.

I think Knoppix tries to check the refreshrate of the monitor, but this works different on an LCD / TFT monitor.
There lies the problem I think...

02-09-2003, 09:36 PM
Try "fb 1024x768" (without "knoppix", just fb 1024x768 at boot line) this works with my two LCD monitors

In Italian market my 38B1 is Known or equivlent to 38B2 in other countries and a datasheet is viewable here:

However :

Horizontal 30 - 60 kHz
Vertical 55 - 75 Hz
and 102x768 is supported with the refresh of 60 hz (48.36, 48.78 KHZ), 70 HZ (56.48 KHZ) ,72 HZ (57.52 KHZ), 75 HZ (60.02 KHZ and 60.24 KHZ)

Thanks for very tips to all

02-09-2003, 10:04 PM
Using Matrox G400 16 MB and Fuitsu Siemens 38B1 at the startup I tried many tips of you( in combination too) and other tips of F2 screen

Then the message is the following
"You passed an undefined mode number. Press RETURN to see mode Vesa mode vailable.. I tried 0 (80x25 ) or 3 (80x28).
It is ok. The coloured text is good and so I can see many hardware well recognized and among these there is Matrox G400 16 MB AGP using XFree86 server - fbdev)
and a generic monitor voice

Tryng fb102x768 the screen is blinking, trying to start X11..
then I can read in text mode:
trying XFree (vesa)...failed
trying XFree (fbdev) ...failed

and then I return to command prompt

What do you think about this?


03-24-2004, 02:06 PM
Does somebody have a clue, how to get knoppix running with a sony cpd-m151 tft lcd?

03-24-2004, 04:28 PM
Hi I gete the same thing on bootup on my COMPAQ presario 1247 laptop. It says the same thing about passing an undefined mode number, and to wait or press space bar to continue, which i always do [press space bar] and it seems to work fine when KDE starts....I did dmesg and looked for any video related errors but found nothing....So I have no idea why it does that but it doesnt seem to be a problem.....i will look into this closer cause i would like it to start with no errors so i dont have to keep hitting the space bar every time! bob :shock:

03-30-2004, 01:52 AM
hi all!
I have a similair problem with mine. i have a old Hewlitt Packard Pavilion monitor. and i also get the you have passed a undefined number to press return for video modes or press space bar to continue. everything seems to load ok and everythings detected. even my monitor but it detects it as a generic monitor. but anyway. it loads but when it gets to where your GUI is sposed to load, all i get is a flicker and then nothing but a black screen. I tried different video modes, tried the xmodule options. even tried telling it to run kde thinking it might be a compatability issue with one of the gui programs. but no such luck. my graphics card is a intel(r) 82810 graphics controller. when i had mandrake linux on my system i had no troubles running. don't have it now. i just have windows xp. I have 128 mb ram. hope this info helps. was hoping some one could help me. thankssss[/b]

03-30-2004, 06:39 PM
If you have problem starting up X, check /etc/X11/XF86Config-4 and remove those modline entries and try again(startx at the command line), especially for LCD monitors.

03-30-2004, 11:19 PM
umm i am a total noob to this lol i know to start it u just type x or xmodule at boot but have no idea how to do the rest. lol thanks