PDA

View Full Version : Running Knoppix on a Toshiba Satellite box



bureado
12-15-2003, 07:51 PM
Greetings,

I'm trying to install a Knoppix 3.3 distro on a Toshiba Satellite laptop. When I started with 'knoppix lang=es' startup worked great, it entered runlevel 2 and then X server was started and I was constantly getting console errors about HDA. Looking at cheatcodes I tried with 'knoppix lang=es dma' and it worked, but now I cannot do 'knx-hdinstall' because device is unmountable.

/etc/fstab says that /dev/hda must be mounted on /mnt/hda but when I try it it keeps telling me that bad filesystem, non valid superblock or too many filesystems mounted, even when I pass 'mount -t vfat /dev/hda /mnt/hda'. I was also trying with the mount command to do 'mount -t vfat /dev/hda1 /mnt/hda' as I do usually with my desktop box, but it tells me that it might be an IDE SCSI unit, that I should try with '/dev/sr0 and /dev/sda'. I've also tried with both and nothing happened.

FInally, I'm unable to install Knoppix in the harddisk, even with the cheatcode 'tohd=/dev/hda1'. I'm a bit desperate because I don't want to use Mandrake!! :(

Thank you very much for any help.

lafar
12-17-2003, 01:42 PM
Hi

Try Knoppix 3.1. As I know such problem does not exist in this version. Run Knoppix without dma cheatcode.