View Full Version : Knoppix will not recognize my Actiontec PM560LKI modem

02-07-2003, 08:25 PM
First off...I'm a Linux newbie. However, I cannot get KPPP to recognize my Actiontec modem. I get a 'modem is busy' or 'modem is not detected' message. Windows configured this modem after I installed...I didn't have to do a thing. I can dail-up and get connected to my ISP thru WindowsXP with no problems. But Knoppix (also Demolinux has the same problems as Knoppix) is not working. I'm sure I just need to configure some settings, but I have no idea what they are. I would appreciate any help you people can give me. Remember, I am a Linux newbie. Command line entries are a mystery to me. Thanks ! javascript:emoticon(':roll:')
Rolling Eyes

02-08-2003, 05:28 AM
There is a good chance your modem is a hardware modem. check www.linmodem.org . As for possible help try www.phpcad.com/knoppix-install.html


02-08-2003, 07:47 PM
Bill...thanks for your help. I have gone to the sites your mentioned and many more. Most of what I read is over my head. I can't find answers that help. I am going to contact my local Linux User Group and see if I can get some hands-on help. Thanks again!

02-08-2003, 09:04 PM

I am new to Knoppix but have had experiance with other distros. I also have a similar Actiontec modem that is not auto detected. I am still working on it but here is something I already know from problems with other distros. Linux drivers are not like Windows drivers, when you search for drivers don't look for the maker of the modem (Actiontec), this doesn't matter. Look for the the chip maker, in my case Lucent.

In my favorite debian distro(Xandros), I also had detection problems but got it working with a Lucent K56flex driver.

In Xandros it was all GUI. Unfortuenetly I am not much of a techno wizard so even if I did have the right driver I wouldn't know how to use it in Knoppix :oops: So anyone reading this please help.

If I ever get my modem to work I will post how I did it :wink:

02-08-2003, 09:10 PM
Somehow my message was submitted twice and I can't find how to delete this.

02-08-2003, 10:03 PM
Ok, that was fast!!! I am now running Knoppix.

I found this little trick that you might try in the hard disk installation HOWTO.

Type this into a root shell:
cd /dev
ln -s ttyS4 modem
chmod 777 modem
chmod 777 ttyS4

This will set up your default modem to run on ttyS4. For Win/DOS users ttyS# is somthing like com#. Why this works I don't know. Why is my modem is on ttyS4? Why can't Knoppix find ttyS4 whith it's aoutodetect? Mysteries that are way over my head. But anyway it worked for me so you might give it a try before begining the desent into Linux driver Hell.

02-09-2003, 06:21 PM
In DOS/window$ terms the standard serial ports (modem ports) are COM1 thru COM4, many pci modems set up on a non-standard serial port, which is COM5 in DOS/windows. In linux COM1 is ttyS0 so ttyS4 is linux terminology for DOS's COM5. Since COM5 and also ttyS4 are "non-standard" ports Knoppix won't look there because it doesn't exist, so you had to make the device /dev/ttyS4 so you could use your modem.



02-10-2003, 02:23 AM
Rock...I have changed my modem to COM4. I did that in Windows. Thanks for your help.

MattT...I tried your Command Line instructions. The "cd /dev" took OK. But the "./ MAKEDEV ttys4" instruction gave me an error message of "don't know how to make device ttys4". Now I'm lost again.

I have a question. After I get Knoppix and KDE loaded I click on the lower-left K, then Knoppix and then "Root Shell" to get to a black box labeled "root" and then type in the command line instructions...is this the same as clicking on Konsole in KDE to get to the black type-in box? I used the first example to type in. I'm clueless.

I have another question. Maybe I just need a Linux driver for this modem. Windows automatically loaded a Windows driver for me. Will a Linux driver conflict with the Windows driver.

Thanks for your help. :cry:

02-10-2003, 03:31 AM
Did you try

MAKEDEV ttys4 or ttyS4

It makes a difference.

02-10-2003, 10:00 PM
SUCCESS at last!!! I am now able to dial-up, connect to my ISP and surf the WWW. :lol:

Thanks to all who helped me. The instructions that MattT gave me along with the advice from AvidLinuxUser (thanks ALU) did the trick.

I am going to play with Knoppix for a couple of weeks then go for a full-blown Mankdrake distro. I'll really have the questions then! :lol:

Again, thanks to all who helped me. Never got the job done without you! :D