PDA

View Full Version : Help! Sound Blaster Live Value



Neb00
12-06-2002, 05:32 AM
Help! I did a HD install every thing is working out great but I have no sound in Knoppix (still get sound in my XP OS).
I have a "Sound Blaster Live Value" card. this is tem message I get.

Infotmatinoal - art message

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will contimue, using the null output device.

I am using the 8-11-2002EN ver. Sound did not ever work when I booted from CD.
I am new at this so what ever you do explain it well.

Thanks Ben

P.S.
Did not spell check becous I wrighting this in KWord and it ti spellin ceecking in German (yes my lanuage is set up as english).
So if anyone knows how to fix that I wuld love to hear form you.

Neb00
12-06-2002, 03:14 PM
OK i think i have a place to start now.
Click on the 'Start Application' in the bottom left hand corner then 'KNOPPIX' then 'Configure' then 'Sound card configuration'. It will state a Wiz to help you set up your sound, this in on the CD I do not know if it will help on the HDinstall I will test it and post hear.
Later
Ben

Carlos_E_Morimoto
01-10-2003, 01:48 PM
Try open a root shell and type:

modprobe emu10k

Aparently sndconfig have problens with some Live cards, but they works after load the module by hand.

jeramy
12-13-2003, 10:56 PM
:(

I have the same problem. I typed in modprobe emu10k1 (I think you missed the "1" at the end), but I still get no sound.

The SB Live! works in every other Linux distro. With Slackware I need to run alsaconfig to get it to work though.

Stephen
12-14-2003, 12:07 AM
:(

I have the same problem. I typed in modprobe emu10k1 (I think you missed the "1" at the end), but I still get no sound.

The SB Live! works in every other Linux distro. With Slackware I need to run alsaconfig to get it to work though.

Try using knoppix alsa at the boot: prompt that being said I have a sblive it always works without the alsa you may want to check lsmod and see what modules are loaded also make sure if you have onboard sound that you have disabled it Knoppix would be finding that as well and could be using it as the default device. If these suggestions do not work can you post the output of lsmod, lspci -v, and some details on the hardware in your machine.