PDA

View Full Version : knx-hdinstall Failure



schoeppchen
01-04-2004, 05:41 PM
Hi there,

I'm getting a strange error when trying to install Knoppix 3.3 on AMD K6 System with 10GB HDD.

When I run knx-hdinstall I get the welcome screen (...this software is beta ... blablabla) and then in next window I get

/dev/ Can't make subwindow [....]

error. Does anybody know how to do about that? It seems as if install can't access my partitions even though they are properly set up, mounted and recognized in /proc/partitions. Before the window comes up I get a strange output on console which says something about /dev/sda and outputs some failures about that device. This device is also shown in /etc/partitions allthough I am not sure which device this should be (I only have on HDD -> hda and 2 cdroms).

Anybody got an idea?

rickenbacherus
01-04-2004, 05:56 PM
Hi there,

I'm getting a strange error when trying to install Knoppix 3.3 on AMD K6 System with 10GB HDD.

When I run knx-hdinstall I get the welcome screen (...this software is beta ... blablabla) and then in next window I get

/dev/ Can't make subwindow [....]

error. Does anybody know how to do about that? It seems as if install can't access my partitions even though they are properly set up, mounted and recognized in /proc/partitions.

You don't want the partitions mounted when you try to install.


Before the window comes up I get a strange output on console which says something about /dev/sda and outputs some failures about that device. This device is also shown in /etc/partitions allthough I am not sure which device this should be (I only have on HDD -> hda and 2 cdroms).

/dev/sda is a reference to a SCSI devivce. Likely your cdrom drive as they are accessed throught scsi emulation. Are you trying to install to a cdrom?

schoeppchen
01-04-2004, 06:27 PM
Ok, now I've tested it a little bit. I always get the following error after welcome-screen, no matter what I do:

-x-x-x-
You have /dev/
Can't make sub-window at (33,12),
size (1,54)
-x-x-x-

My Partitions are:

primary 7,8GB ext3
extended
logical 0,2GB swap

I tried the following:

- call knx-hdinstall with mounted partitions
- call knx-hdinstall with unmounted partitions

I even deleted all partitions and tried to run knx-hdinstall, but I always get the same error.

What's wrong? Perhaps my harddisk is too old for Knoppix, but that would surprise me. Running 'badblocks' gives me no bad sectors....

:?: :?:

rickenbacherus
01-04-2004, 08:17 PM
Never seen that error before- try knoppix-installer instead.

schoeppchen
01-04-2004, 11:58 PM
knoppix-installer lets me partition the disk - but I can only select "Partition disk" and "Quit" but nothing else. So after partitioning disk I cannot do anything but Quit. Should there be another selection?

Ice
01-05-2004, 02:02 PM
Hi folks,

I have exactly the same Problem:
When I try to install Knoppix 3.3 version of 19.11.2003 using knx-hdinstall i get a similar error saying
"You have /dev/
Can't make sub-window at ..."
I' trying this on a Shuttle barebone with an on-board ProSavage DDR graphic chip, a 1300Mhz Duron and a 180GB HD with /dev/hda9 as last Partition of 2.6GB
It doesn't matter if the partitions are mountet or not, I even tried changing the xmodule; vesa instead of savage.

It may be an issue with the graphics chip, which is currently not 100% supported.

The confusing thing is, on all other Machines I ever tried knx-hdinstall it works...


Ice

P.S. My first post at this site! :)

rickenbacherus
01-05-2004, 03:47 PM
knoppix-installer should indeed give you manyu options. Maybe try booting knoppix 2 and then run the installer from there.

schoeppchen
01-05-2004, 04:00 PM
I always start up using 'knoppix 2', no need for X on a server :D

I think the whole problem has something to do with a failure in recognizing the partitions. I will do some analysis later and maybe I find out why all this happens.

Stephen
01-05-2004, 08:34 PM
knoppix-installer lets me partition the disk - but I can only select "Partition disk" and "Quit" but nothing else. So after partitioning disk I cannot do anything but Quit. Should there be another selection?

Have you formated the partitions? If not try that and then run the installer.

schoeppchen
01-05-2004, 09:08 PM
Yes, they are formated.

I found the bug or whatever this is. In the scripts everytime a choice has to be made (e.g. hdddevice, swap device, root partition) a radio-list is generated. The result of the choice (what the users selects) is outputed via pipe to a file in /tmp. This list cannot be generated on my system and so the output of the list is not the result of the user select but the error message "can't make sub-window[...]". This "result" is written into that file and when this file is beeing processed (in the next step the read in the users choice), this error-message is considered to be the input of the user. So e.g. the "selected" hdd is

/dev/can't make subwindow[...]

and this device doesn't exist :D

The question now is, why this radio-list cannot be generated and the errors is thrown :?: :?: :?:

schoeppchen
01-05-2004, 10:07 PM
After more testing I finaly got knx-hdinstall to work. The problem was

....
....
....

that dialog crashes on my system (and outputs the message Can't make subwindow[...]) when getting german special chars (such as '' '' '' or '') within the --backtitle or --text option.

I would consider replacing those chars with the correct substitutes, a simple

sed -e 's//ae/mg' -e 's//oe/mg' -e 's//ue/mg' -e 's//Ae/mg' -e 's//Oe/mg' -e 's//Ue/mg' -e 's//ss/mg' knx-hdinstall

will do the trick for all of you who have the same problem.

Perhaps someone with knoppix-devel-rights should fix this in the next release for people like us :D

Allthough I do not understand why only I get this error on my machine, something with localization perhaps wrong on my system?