PDA

View Full Version : Booting Problem



RayN
01-17-2004, 07:25 PM
Hi all. For some reasone when i run knoppix from cd, when it detects the sound card it says "soundcard:modprobe: modprobe:can't locate module sound slot -0
modprobe: modprobe:cant locate modyle sound-service-0-0"
any clues as to how i can bypass this. I have an HP omnibook 4150 laptop.
At the boot I did type "knoppix noaudio" btw....
Any suggestions would be very much appreciated, as i am now stuck with having no OS, after i scratched my windows 2000 cd up:-(
All the more reason i should switch to something better...
You can always MSN, or ICQ me, I'm very much so stuck on this.

baldyeti
01-17-2004, 07:32 PM
Do you mean that the boot freezes after this message, refusing to proceed? Have you tried "knoppix alsa" at the boot prompt?

RayN
01-17-2004, 07:38 PM
Yes i did try that. the same thing occured. I also tried going to expert mode, and selecting what i want loaded. After it asked me if i want to reconfigure the mouse, the same thing occured (it bypassed the sound without a problem)
I went to the failsafe option, and it's been loading fine so far (it's writing paging files right now), but i'm sure that it skipped apm, and other useful modules, that i will most probably need for my laptop... any ideas....

baldyeti
01-17-2004, 07:49 PM
There is an article here (http://linux.oreillynet.com/pub/a/linux/2002/09/19/linuxlaptop.html) that ddresses your very problem. It might be obsolete though, since it refers to the 2.2.x kernel. You could try and see if the modules they had to load still exist under 2.4.x.

markt2000
06-18-2004, 03:42 PM
Yes i did try that. the same thing occured. I also tried going to expert mode, and selecting what i want loaded. After it asked me if i want to reconfigure the mouse, the same thing occured (it bypassed the sound without a problem)
I went to the failsafe option, and it's been loading fine so far (it's writing paging files right now), but i'm sure that it skipped apm, and other useful modules, that i will most probably need for my laptop... any ideas....

I got my Omnibook 4150 going by doing: "knoppix noagm"
before doing that, it used to hang after the "configuring devices ... Done" stage.

Then, once up, I got the sound going by opening a shell, typing: sudo su (to be root user), then typing:


insmod soundcore
insmod sound
insmod mpu 401
insmod opl3 io=0x388
insmod ad1848 io=0x530 irq=5 dma=1 dma2=0

Some of that may be redundant and there may be easier ways to do it at boot time, but haven't played too much (this is what worked for me on an old redhat install too).

markt2000
06-18-2004, 03:45 PM
I got my Omnibook 4150 going by doing: "knoppix noagm"

Whoops, I meant: "knoppix noagp"[/quote]