View Full Version : Knoppix cd wont boot, other bootable cds will

01-19-2004, 07:16 AM
Hi, I'm trying to boot a KnoppMyth cd here but I get the same error with Knoppix STD:

bios info:
cdrom is first boot device
hdd is second
third is disabled
both the A and B drives are set to "None"
boot up floppy seek is set to "Disabled"

heres what I get
-----------begin output-----------------
Verifying DMI Pool Data..................
Boot from CD :
1. FD 1.44MB System Type-(0F)
Boot failed

----------end output---------------

I can boot of off a Mandrake Move cd, System Rescue cd 2.8, and my Fedora Core cd but neither Knoppix STD, or KnoppMyth will boot.

I've tried swapping the cdrom drive, and have even tried putting in a different hard drive. I also get the error whether there is a floppy drive connected or not.

Mobo is a Gigabyte GA-7s748
Chipset SIS748
CPU Athlon XP2200+ 1808MHZ
256MB of RAM

01-19-2004, 08:01 AM
Here's what works for me:
Set the BIOS to boot sequence CDROM, C, A: (or any with CDROM first)
At pwr-up or reset, get your drive door open, and wait until the BIOS is polling the drives for type, size, etc. The controllers respond with "primary Maxtor, blah blah, secondary not present; secondary drive controller master PCRW804 or whatever, blah blah."
WHILE this polling takes place, shove the drive door closed (a gentle push won't hurt, but use the close button if possible.) Usually my disk-in light begins to flash once/sec immediately. _IF_ I get the timing right, the controller begins to handshake the cd drive to read the boot sector at just the right time to catch and read it. This is indicated by a continuation of the flashing disk-in. I've missed it if the light starts flashing dimly, and the BIOS starts to boot from C. Time to hit reset again...
I noticed this first with Knoppix 3.2 from last summer; never happens with the 3.1s I've got.
This tricks the drive/controller into reading the boot sectors without pre-positioning to where it THINKS the boot sector should be, and instead SEEKING it. I've found that after changing my boot sequence and booting from floppy or even another cd and then Knoppix it sometimes will boot right up; usually the first attempt of the day works, too. Annoying, yes, and the ugliest of solutions, but perseverence pays off.

01-19-2004, 08:27 AM
so you were getting this same error?
When you boot from another cd exaclty how do you then boot knoppix, do you power down, what kind of cd are you using.
I can't seen to get the timing right on the "slam the door in its face" technique so I'm going to have to look into making a boot floppy.

Thank you for your help.

01-19-2004, 05:26 PM
Yes, same type of error, first noted on a 3.2 disk last summer. This 3.3-11-19-2003 disk boots just fine on other machines, just not on my antique built-up-from-scraps box. (Well, the cd drive was new, a Phillips 804.)
I coax it to read the boot sector properly by first confusing it as to where it is: a game of first booting from 3.1, then resetting the BIOS to boot from A:, then back to cd, try the 3.3, or any combination, or pwr-off reset, or saving new BIOS settings, or rewriting the MBR of the drive, or de-or-inserting a USB device, or well you get the picture: confuse the drive controllers until they give in and actually READ the boot sector cleanly, in one read. IF you see it start to read, and then slow down, it's not gonna work. Try again. On my drive, I know it's confused enough when the once/sec flash of the disk-in light glows constant, and then resumes the once/sec when the BIOS displays "Boot from ATAPI CDROM". Poof, here comes 3.3 in a couple seconds. (As I write on this iMac, it's booting for me yet again after a tussle, readying for another attempt at hdinstall.)
I think this problem might have something more to do with the CLOOP technique of compressing all that good stuff onto one disk; I'm not sure, but it appears to need to read out through the filesystem too far, and isn't finding the end of the boot sector, or could be overflowing the drive buffer before it finishes the read... Guess only Klaus knows for sure... I just wish the BIOS would let me extend the time for cd boots before defaulting to C or wherever.
Better get back to my X issues on the ancient SpeedStar64 isa card... Ugh.

01-19-2004, 06:18 PM
Ok, here's what just now worked yet again:
Found the nice KDE desktop on the latest fresh boot from cd3.3, only the mouse was dead this time. SO, since I went down there (basement hardware hideaway) to swipe the USB drive from that box, I changed the actual drive hardware present.
Then I went about the reboot of the box, hoping to get the drive to read that cd once again. Ha! Joke's on Bill. Seems removing that drive hardware (scsi-emulated usb drive) FORCED the BIOS to poll the drive devices upon boot, instead of reading saved HW info, thus making the cd drive report what it is, and where it's boot sector is, thus making it readable. This is what the "slam-door" technique is after. Sometimes that works, if the disk-change feature reports back to the BIOS that it IS something new here, not just that it's GOT something new in here. I'd imagine it would boot every time if I disconnected the drive cable each time. But that's just not going to happen.
Removing the USB device apparently resets the BIOS HW table, as would installing a new mass storage device, wherein the BIOS polls each drive and rewrites.
BTW, that's a _2_ meg dram SpeedStar64 ISA card, and it boots X just fine from the CD (well, 8-bit), but not from the HD install. Something fishy here...