View Full Version : hdd instal from kpx live cd

dutch noob
01-23-2004, 05:16 PM
hi guys sorry to bother u but i just tried KPX live cd and i love it ,i tried mandrake and red hat but that wasnt how i want it

so i like KPX very much

but is it possible to instal it from the live cd on the Hd or do i need to get another copie of it
and if its possible how do i do that :oops:
iv read some topics about it but not all the info was there what i needed

i hope some of u guys want to help me
i very apriciate it

01-23-2004, 06:18 PM

has all you need to get you going. You just boot up the live CD and follow the instructions.

If you need to re-size a Windows 9* partition, it's essential to run a full defrag and scandisk routine first from within Windows. If you have an ntfs file system (Windows NT, 2000, XP) you'll almost certainly need either a proprietary tool or (heh, heh) to do the initial resizing from a recent Mandrake installation disk and then abandon the Mandrake installation after it has resized the partitions.

There's a lot more under the "Docs" tab above (on this page), and there are other installation scripts and methods apart from the knx-hdinstall routine used in the McNabb article above. But I've always found the knx-hdinstall script to be the best of the bunch.

If you are worried about screwing up your Windows install, the easiest way is to buy another hard drive and fit it and install Knoppix on that. After you've installed Knoppix, it's pretty easy to get Lilo to dual boot both Operating Systems.

dutch noob
01-23-2004, 06:42 PM
thank u very much fingers
im going to do it right away
ive read and printed the tutorial u gave me and i am very happy with it

and yes im going to use a other HD to install Knopppix
but i have 1more question is it really necesery to use a boot loader
cos maybe if i want to go 4 knoppix only i still have that boot loader , or is there a way to remove that to ?

i know ist a stupid question about the bootloader but its a small thing 4 me to choose what is booting in ,or am i just beeing a Total Noob now :oops:

o yeah thank u very very much :D

01-23-2004, 08:01 PM
If you are just running Knoppix you can either

boot from a boot floppy or

install lilo

It's wise to make a boot floppy anyway (use a fully -- dos -- formatted floppy -- often floppies which have only had a "fast" format don't have enough space on them) but Lilo makes life much simpler (and the booting is quicker). Under the knx-hdinstall you'll get prompts to do both. Just follow the instructions.

dutch noob
01-23-2004, 10:55 PM
oke i got it installed without any problems :lol:

but i cant get on the internet i need to instal drivers so i used packetmanager but now he wont install my internet driver cos they need to b converded
with alien

so after alot of looking and searching for alien i found it
i just opend console and typed alien ,iv been trieing to convert it but i wont work :(

is there another way to do this ??
i got a asus a7n8x-x mobo but the only files i find on the web r rpm :(

and i got another litle prob to it
my Cdrom +dvd players wont work when i click the shortcut on the desktop it says that i dont have it ...but oke that a prob 4 later

i hope u guys can help me
and sorry 4 all the questions guys ,but i just want linux on my box :(

01-24-2004, 12:15 AM
What drivers do you need?

I'd be surprised -- shocked even -- if there were no drivers available (well, drivers which are available as rpms, IYSWIM) as either deb or as source.

These should be your first choice before resorting to alien.

dutch noob
01-24-2004, 12:39 AM
i need the nvidia nforce 2 chipset (4 my a7n8x-x) drivers these drivers include my networkcart drivers to :( my network cart is onboard
but i think i found em but they r tar and i dunno how to instal that stuff :oops: been trieing it but it wont work

i tried netcardconfig to but it doesnt c my card at all

sorry if my grammar is a bit messy but im dutch ;)

01-24-2004, 01:55 AM
To untar in Kde (by far the easiest way), just right click on the tar file and select "Extract Here".

This should create a new directory in the directory you're actually in. Let's imagine that it's in your /home directory and that the new directory is called /whatsit.

As yourself, do

cd /home/dutch_noob/whatsit

(or you can do this graphically in Kde)

find the readme file and open it. It'll give you the instructions. But normally the steps to build something are:

(cd to wherever the configure file is -- do this in a Konsole/Xterm)


./configure && make

then sue to root

and do

make install

(but proprietary drivers sometimes have wierd build methods!)

Let us know how you get on -- I'm off to watch Buffy!

dutch noob
01-24-2004, 03:16 PM
okay after alot of trieing and more trieing i installed the drivers
but still it can not find me network cart ,it says no supported networkcard detected and i am sure i have used the right drivers

so i am really stuck now every time i need to go back to Ms to go online :( :?

this is how i installed em

cd to where they where << the drivers
make i saw him building the Software
make install

but still no luck

01-24-2004, 03:57 PM
If you didn't get any errors during the build process, then the drivers are built. But I think you may need to insert them manually.

If there is nothing in the instructions (usually you'll have to put a reference to them in something like /etc/modules.conf), can anyone else help?

dutch noob
01-24-2004, 11:56 PM
erm i got internet now cos i installed a networkcard that i nicked from my sons pc:)

after alot of trieiing with the onboard cart i just gave up

but now i got another problem thats need to b sorted that is
my shortcut to my cd rom aint working is say i dont have it :S

but i think i saw another tread about that subject so im gonna read that 1 to

01-25-2004, 12:35 AM
It's usually because it's pointing to the wrong place. Check the floppy, too!

dutch noob
01-25-2004, 01:47 AM
after reading the tread http://www.knoppix.net/forum/viewtopic.php?t=7353 i saw the guy had the same problems as me and he reinstalled his knx with knoppix-installer insted of knx-hdinstal

and voila problems solved

thanks fingers 4 ur great support :)