View Full Version : connecting with 3com home connect ADSL

01-28-2004, 10:07 AM
Hi to everybody,
i'm fresh new user of knoppix, and i'm very satisfied.
But i've a couple of problems... one of these is:
if i run the "ADSL/PPPOE configuration utility" to connect via my 3com ADSL HOme connect ethernet modem this program try to configure the card and the modem.. but then says that the ACcess COncentrator of my provider doesn't respond .. mmm.. :-s what does it mean?

Instead, after i installed rp-pppoe i manage to connect trhough the net. If i can't solve the first problem, at least i'd like to start the connection at boot, so all the users of my pc can have the connection, and they don't have to run rp-pppoe utility with root privileges.

Anybody can help me? Maybe there is something i've to do to configure the ethernet card (is a 3com 3c509b III Isa net card)?

Thanks very much in advance!!!

01-31-2004, 10:23 PM
Mentioning the 3com 3c509b III Isa net card is indeed helpfull.
This as an old card which to my knowledge doesn't support plug-and-play.
You have to use a dos-boot floppy and use the progrma from 3com to set (or view) the IRQ and I/O adress of the card.

So first check if the network card is running properly under knoppix.

For the ADSL modem ,can you insert a link in this forum-thread which explains what exact modem you've got ?
This makes it a lot easier for anyone to help you.

02-01-2004, 07:27 PM
Thanks for the suggestions!

Well, i tried with ifconfig and the card seems to be recoignaised by the system (now i'm writing from Windows, because i don't know why not the connection with rp-pppoe starts, but i can't surf... so i can't paste what the pc tells about the card.)
The utility pppconfig allows me to set the address of the card, that by default is , the gateway,netmask and so on..

In the rp-pppoe readme file is written that to allow the connection at startup the net-card "DOESN'T have to be loaded " at boot, and to insert a line in a file, the rc.local in the rc.d directory.. but this folder doesn't exist (only rc.d0 rc.d1 etc..)

I'll try downloading the drivers you suggested me, and if this doesn't help well... i'll try with two other netcard, hoping that are working correctly!!

The modem is this : http://www.3com.com/products/en_US/detail.jsp?tab=support&pathtype=support&sku=3CP4130

I hope this can help you finding the solution... if i'll have some spare time tomorrow i'll try to set the other cards.

Thanks again!

02-01-2004, 10:38 PM
I think the module neds to be loaded but not configured since it doesn't use tCP IP to find the pppoe interface.

You need to hqve the modulke loaded else it will say it found no cards.

try as root
and look and see if the 3c... drver is loaded or not