View Full Version : Card Reader, not a valid block device?

01-31-2004, 12:07 AM
I know this has been thrashed out in the past, but the suggestions I have tried seem to relate to cd boot.
My Card Reader mounts and is workable in 3.3 from cd boot, but in Hdd install it throws out the valid block device message and won't mount.

It shows as device sdb1 in cd boot for compact flash. Any suggestions?

Any replies in noob speak please :D

01-31-2004, 04:20 AM
My guess is that if you do (in a Konsole or Xterm)

(root password stuff)

gvim /etc/fstab

you'll find that the entry which relates to your usb has been hashed out ( a # is a comment in many scripts and languages: it means "ignore this line"). Just remove the hash (hit the "i" key, delete the hash and save the file) then do (still as root):

mount -a

and all should be fine.

01-31-2004, 05:17 AM
Thanks, none of the lines were hashed, I decided to try using my older reader to see if that would work and it mounted fine. Odd how the new one is ok on the live cd.

Is there a command that will list the device suffix of the reader once connected?

01-31-2004, 11:31 AM
Try booting up with the Knoppix CD and take note of all the modules loaded but using the lsmod command. Also take a look at the /etc/fstab.

I have two machines that have Knoppix installed to the hard drive. One the card reader mounts fine on, the other it gives a not valid block device message but mounts without complaining on retry. The installs are virtually the same and the same card and card reader are being used. They both use usb-ohci too. I haven't the foggiest why this is but the moral is to reissue the same mount command and see if it works.

02-01-2004, 05:28 AM
Still havn't quite nutted it out, on live cd, the lsmod is the same with both readers:

usb-storage 60960 1
usb-ohci 18184 0 (unused)
usb-uhci 21868 0 (unused)
usbcore 57472 1 [printer scanner usb-storage usb-ohci usb-uhci

The weird thing is the old reader mounts as sda1 on cd, and on hdd it mounts as sdb1?
I've tried mounting the new reader as sda1 & sdb1 with the mount command in live cd and normal command, both to no avail.

Here is fstab for new reader in live cd;
# Added by KNOPPIX
/dev/sdb1 /mnt/sdb1 vfat noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0

Oh well at least I can use the older one for the mo, just don't like being defeated by a circuit board!!

02-01-2004, 06:17 AM
In order to get my dual-card reader working I had to put a line like this my /etc/modules.conf file and reload the module:
### update-modules: start processing /etc/modutils/scsi
options scsi_mod max_scsi_luns=2If your reader is dual-card that may help. Also if you have other SCSI devices it doesn't hurt to bump the number up.[/code]

02-01-2004, 06:32 AM
Thanks, got the edit conf bit, how do i reload?

02-01-2004, 06:41 AM
Morsk; I don't have this line in etc/modules.conf;
### update-modules: start processing /etc/modutils/scsi

I assume you mean to add that as well?

02-01-2004, 08:25 AM
Morsk; I don't have this line in etc/modules.conf;
### update-modules: start processing /etc/modutils/scsi

I assume you mean to add that as well?

You should create a file named scsi in the /etc/modutils directory then enter in the required line in said file then as root update-modules to have the information enter into the /etc/modules.conf to be used on the next reboot. Do not edit the /etc/ modules.conf directly the changes you make will be overwritten the next time any setup program or you run the update-modules program, the information in the file comes from the contents of the files in the /etc/modutils directory that is the "start processing" part that is in your post.

02-01-2004, 10:00 AM
Thanks for clearing that up Stephan ~ I really mangled that :oops: Been a long time since I did that... Linux is just too stable :wink:

02-01-2004, 11:48 AM

When rebooting, the GUI doesn't load and stays in command line mode,

What command can I issue to get back to normal?

02-02-2004, 04:53 AM
Resolved the GUI issue, (see "Can't boot int GUI" post)

Still working on the card reader fix. :)