PDA

View Full Version : Problems booting vmlinuz-2.4.22-xfs without Knoppix3.3 CD



alex52
01-31-2004, 10:40 AM
Sorry, I’m new in this forum, and at first, posted this question in General Support, next I’ve read all “HDD Install” section and I’ve not found answer for my problem.

It was possible to copy Knoppix-3.2 core to HD and use it faster from there, but Knoppix-3.3 cannot find core on any (vfat, ext2, ext3) HD partitions (i.e., mount them), and also refuse to perform boot commands “fromhd” or “tohd”.

Additionally, kernel vmlinuz-2.4.22-xfs boots only from Knoppix-3.3 CD, or with initrd=/miniroot.gz in lilo, but if it boots without Knoppix-3.3 CD it ends with “Kernel panic, cannot mount root partition …”. I tried recommended for this case: knoppix mem=256M without success (also tried 249M, 248M, 247M as 8M is used for integrated video, and other kernels recognize usable 248M).
What is a problem?? How to boot this kernel when entire Knoppix-3.3 (or only compressed core) is copied to HD??

I’d like to add than copied to HD Knoppix-3.3 works good (with some restrictions as vmlinuz-2.4.22-xfs modules are not loaded) after booting in other kernels as from floppy or HD lilo, or by linld.exe, but vmlinuz-2.4.22-xfs led to “kernel panic, cannot mount root ...”

In HDD Install I met in lilo:

initrd=/boot/initrd.gz

What is this initrd.gz ?? Where to get it??

initrd=/miniroot.gz placed on HD from Knoppix CD led to the same result , i.e., Sorry, cannot find Knoppix.

Any suggestion??
Best, Alex