View Full Version : Printer installation problem

02-01-2004, 08:04 AM
I have three printers connected to my machine via a USB hub: an HP 1000 LasterJet, an HP 7550 PhotoJet and a HP 2310 OfficeJet.

Some time ago I configured them using the Peripherals part of the KDE Control Center, selecting printers and then changing to Administrator Mode.

I then used the Add Printer option and follows the KDE Wizard. Even though all three printers appeared as USB printers, and the printer selection from the HP menu was easy. Everything worked ok.

Since then I have updated and upgraded the system many times, and recently the HP LaserJet 1000 has stopped working...

No errors, no messages, but no output... If I boot WindowsXP it works fine, so it is not a connection problem.

I tried reinstalling it and now KDE tells me that it cannot find the driver. After selecting the HP 1000, it offers me two selections, the first being:

HP LaserJet 1000 (Foomatic + foo2zjs) [recommended]

Which when I select it, gives the following error:

It is not possible to create the Foomatic [HP-LaserJet_1000,foo2zjs]. Either the controler does not exist or you do not have the necessary permisions to undertake this operation.

Since I am running the wizzard as root, it can not be a permissions problem...

Soooo, I searched around and found a Laserjet driver in /usr/share/cups/mode (or something like that) and selected it from within the KDE printing Wizard, and it was accepted ok.

However, when I try to print a test page, KDE thinks that it has sent the page ok, but nothing comes out on the printer...

Any suggestions?



02-01-2004, 04:24 PM
Hello timread,
maybe this site helps:


It has got instructions about how to use the Windows driver package. They write that this method was tested by others...

02-01-2004, 11:49 PM
Thanks for your advice, I have tried the steps they suggest, and when I cat the .img file the printer comes to life, but still does not print afterwards...