View Full Version : iteraid boot problem

02-02-2004, 03:21 AM
Hi, i'm new here, and at first i want to say sorry for my bad english, i'm from Austria.
I'm not a total noob in linux, i worked with suse 6.4-7.2 but then i got Wind***XP and i used it without any problems.
Then i got a DBox2, and the first thing i did is to flash Linux instead of the Betaresearch crap.
Now i wanted to make my own Linux images for my dbox, and this requieres a computer with linux installed.
I started Knoppix 3.3 from CD and was really happy because almost everything worked without any problems, except my Audigy (i don't care about that now, maybe later...) and my ITE 8212 onboard raid controller.
I have two Seagate Baracuda IV with 120GB and 8MB Cache in a raid 0 array.
I searched for a driver or something like that, and i found the driver source.
I compiled it under Knoppix with some tricks, but it worked fine.
When i boot my Knoppix cd, and enter expert as boot command i can load my iteraid.o module, and everything works. I can read and write without any problems to the harddisk.
The next step was to install Knoppix on my harddisk, first i tried it with the knx-hdinstall script, but it didn't work.
When i started linux from harddisk i got a kernel panic, unable to mount root fs.
Ok, i thought, can't work because the module is missing, and looked in this forum till i found something i hoped that it would work:
1) cp /usr/local/bin/knx-hdinstall /tmp
2) mkdir /mnt/work
3) mount -t vfat -o loop,ro /cdrom/KNOPPIX/boot.img /mnt/work
4) gzip -cd /mnt/work/miniroot.gz > /tmp/miniroot
5) umount /mnt/work
6) mount -t ext2 -o loop /tmp/miniroot /mnt/work
7) cp /lib/modules/2.4.22-xfs/kernel/drivers/scsi/aacraid/aacraid.o /mnt/work/modules/scsi
(i copied my iteraid.o module there)
8) umount /mnt/work
9) Edit knx-hdinstall and change:

* * * mount -t vfat -o loop,ro /cdrom/KNOPPIX/boot.img $TL1
* * * gzip -cd $TL1/miniroot.gz > $TR/miniroot
* * * umount $TL1
* * * cp /tmp/miniroot $TR

10) rmdir /mnt/work
11) /tmp/knx-hdinstall
It's not for the iteraid module, but i think it should work too.
I did everything like descriped, but it didn't work again.
When i boot from hdd, i get a kernel panic agian that says unable to mount root fs.
I looked at the screen, and found the following line:
insmod iteraid.o:
I was thinking ok, it try to load the iteraid module but it doesn't work, why i don't know.
Then i started again form cd mounted my iteraid module and looked whats wrong. I uncompressed the /boot/initrd.gz file, and mounted it. I looked into the modules folder and found only the xfs.o and no iteraid.o.
Ok, no iteraid, thats the reason why it can't load it. I copied my iteraid.o to the folder unmounted it, and compressed it again with gzip. Then i replaced the original initrd.gz with my new one.
When i boot now from hdd, it can't uncompress the initrd.gz, it freezes, and the last message i get is:
Found compressed image (or something like that can't remember clearly).
What's the problem? Why doesn't it work? Why doesn't the modified knx-hdinstall script copy the iteraid.o to initrd.gz?
How can i get it work?
Thanks, i know it's a really long post, but i wanted to explain it as good as i can, and again sorry for my bad english.

02-02-2004, 05:46 AM
I fixed the initrd.gz problem, now it loads but i still get the kernel panic: unable to mount root fs.
It doesn't load the module, there is a line:
insmod /modules/iteraid.o:
But there are no more messages about that.
The next line is from the XFS module, that loads without any problems.
How can i get the iteraid.o module to load?