PDA

View Full Version : Knoppix 3.3 on HDD and 2.6.1 kernel



bobalex
02-02-2004, 01:18 PM
Anyone managed to succesfully boot a 2.6.1 kernel on a 19-Nov-2003 3.3 Knoppix distro installed on HDD ???

I have tried almost everything but upon booting when the process gets to fsck this fails (tried with both ReiserFs and ext3).

Thank you for any reply.

Bob

toconnor
02-03-2004, 03:38 AM
Yep.

I'm new to Linux myself and am having other problems (http://www.knoppix.net/forum/viewtopic.php?t=7831), so I'm not sure I could be a whole lot of help.

I compiled the 2.6.1 kernel. I would hope you're not using a binary distribution, if so, that may be your problem.

I did have a problem booting on my first compile. I originally set things up on ReiserFS, but I seemed to have left support for it out of my kernel. So, I booted into the old kernel and recompiled. Then it worked fine.

I also had some issues with lilo, but it sounds like you're way beyond that.

It might help if you posted the errors that you get from fsck.

FYI - I'm on an AMD/nForce2 system, if that matters to you.

kiekerjan
02-03-2004, 05:22 PM
You might try to update some of the packages. This article (http://kerneltrap.org/node/view/799) describes how to update to the 2.6 kernel. Step 3 describes a number of utilities you need to upgrade.
I used the article to upgrade and everything is working fine.

Worm
02-03-2004, 09:00 PM
Did you use an initrd in lilo.conf or since you compiled support for ReiserFSinto the kernel, did you avoid that problem.?

I am trying to compile 2.4.24 and just cannot get it to work either way. Using an initrd causes a kernel bug during boot and trying it without an initrd causes an unuseable system that spews dozens of error message just as 'INIT knoppix 2.78....' appears in the boot sequence. My tale of woe is at
http://www.knoppix.net/forum/viewtopic.php?t=7814

Did you do it the Debian way with 'make-kpkg' or individual 'make' commands? What steps did you have to do? I have read numerous instructions and they are pretty consistent about how to do it the Debian way, but it just will not work for me when I reboot. I think it is related to handling modules which seem to have slight variations in each set of instructions.

I may just throw away 2.4.24 and take the leap to 2.6, but somehow I think I will get tripped up with the same issue as now. Besides, from the DRI-devel list there are far fewer problems using older kernels rather than new since this is what they are being developed against for the most part.

bobalex
02-04-2004, 06:54 AM
Dear Worm (not intended to be an insult 8->),
thank you for trying to help.

I have compiled the ReiserFS and ext3 into the kernel. I have compiled the 2.6.1-mm5 kernel as follows:

make xconfig
setup all proper values
make_kpkg clean
make-kpkg kernel_image modules_image
then did a dpkg -i of the resulting deb
checked the /etc/lilo.conf in order to be sure I had both the new and the old kernel in my boot list.

Now the questions:

1) Despite fsck failing the systems boots just fine !!! When fsck.reiserfs or fsck.ext3 say the filesystem is not ok I can give the root password and my filesystem looks perfectly aok !!!!!!

2) What is needed to build an initrd kernel ? How do I specify what modules go into the initrd ?

Thank you. Bob

Worm
02-04-2004, 02:51 PM
use 'make-kpkg' --initrd kernel-image modules-image

You will then have an extra file copied to boot called initrd.blah-blah-blah. When you edit lilo.conf for the new kernel add the line
initrd=/boot/initrd.blah-blah-blah just like in the default entry there is
initrd=/boot/initrd.gz

To make sure the kernel is compatible with initrd, make sure initrd is checked Y when you use 'make xconfig'. It is at the bottom of the one xconfig window (I think the file system button) . It is the last button in one of the windows early on.


By the way, do you have an IDE or SCSI system?

bobalex
02-06-2004, 08:18 AM
use 'make-kpkg' --initrd kernel-image modules-image

....

By the way, do you have an IDE or SCSI system?

Thanks for the initrd tutorial :D

It is an IDE system (IBM Thinkpad T40).

May the force be with you. Bob