PDA

View Full Version : Can't boot from Gag



Uncle Fat
02-05-2004, 01:25 AM
I've read a few of the 'can't boot' threads here, and have a similar problem. The only thing different is that I don't really want to use lilo. I'm using gag, and like it. When I try to add my debian partition (installed to HD from Knoppix CD) , gag gives me a "no bootable sector" error. I can use it to boot into XP, and BoOS, but not Debian.

And, please understand (before anyone says "gag is a piece of crap") that I tried lilo, and got the same problem as the other's I've read (It doesn't seem to write to the boot sector: I get 'GRUB' and nothing more.

Is there a way to just make the Debian partition bootable without the floppy?


Thanks.

garyng
02-05-2004, 06:25 AM
GAG as far as I know is a 'boot selector', not loader. Meaning it search the partitions for boot sector and boot it(just put that 512 byte in memory and jump to it). So you must install a boot loader and for linux there is 3 as far as I know :

lilo, grub or syslinux. lilo and grub can handle almost all partition type(where your linux is installed), syslinux is limited to FAT/ISO9660.

you have to tell lilo/grub to install itself to the partition you have installed linux. Then GAG should see it and boot from it(assuming it is at least that smart rather than checking some 'bootable' flag which is for the ancient MBR usage).

Uncle Fat
02-05-2004, 04:23 PM
Thanks Garyng,

I was under the assumtion that lilo was just a boot selector as well. I removed the boot selector lines from the lilo.conf file, and ran lilo. Worked like a charm. Thanks for helping a newbie....