PDA

View Full Version : Dell inspiron 5150 works with nosmp



moustache
02-11-2004, 02:42 AM
Knoppix version 3.3 (2/9/04-en) finally works on my Dell inspiron laptop using the "nosmp" cheatcode! The broadcom 10/100 ethernet card, sound card and even radeon 9000 graphics card (no 3d though) all work as well!

Thanks again Klaus!

moustache

windos_no_thanks
02-11-2004, 08:21 AM
Hmm, sounds promising since it would render my smp-free remaster obsolete and I could go back to using only the official version. Unfortunately it still seems to behave (lockup after loading the mfsroot) like the previous versions on my machine, a Clevo M410E. :-( Is "nosmp" the only cheat code you used ? Has anyone else who previously experienced the same problems tried this ?

moustache
02-11-2004, 10:59 PM
Yes, "nosmp" is the only cheatcode I used and it worked on my Dell Inspiron 5150. I know about the previous experimental version of knoppix you made (thanks) that worked on my laptop as well. Try some more cheat codes along with the nosmp because it is much simpler than remastering (I know I couldnt do it unless it was something like Morphix which is fairly easy to modify). I also got a "berry" (Japanese) version of knoppix that would boot on my laptop. Also you could try the PCLNOS liveCD based on Mandrake ( http://www.pclinuxonline.com/ ) which also worked on my laptop without any cheatcodes.

Moustache

windos_no_thanks
02-12-2004, 04:06 AM
Hmm, have you done any bios or hardware changes lately ? If you have and you still have one of the old versions that didn't work earlier it would be interesting to see if they still fail. :-)

moustache
02-12-2004, 01:52 PM
Actually, yes I have updated the bios (several times) up to version 31 now I think. The hardware has stayed the same (3ghz pentium, radeon mobile 9000 graphics card, broadcom 10/100 nic. builtin sound card). I think I will check some older versions because now morphix will boot on my laptop as well.

Moustache

kirupa
02-14-2004, 08:42 PM
I tried nosmp and was unable to get it to work on my laptop moustache :) I have the exact same laptop and laptop configuration as you also.

booty
02-16-2004, 08:35 PM
NoSmp works! :D :D

I too have had problems with the past versions of Knoppix, and my only way thus far to enjoy Knoppix has been through Windos_no_thanks' modified version. So last night I though I would give the new version a shot. I downloaded V3.3 2004-02-16, and then was able to run it this morning on my Dell 5150 using only the cheat code:

Knoppix nosmp

I booted up on the first try! Everything worked except my net configuration stuff, but I really haven't messed with that yet, since I really have only had one other version that worked and I don't believe windos had the Orinoco driver/broadcom drivers I needed installed on his (I might be wrong, sorry if I am). So this problem is probably due to my ignorance in how to setup my net connections! BTW, I have a Dell TrueMobile 1150 wifi card w/ updated firmware to Orinoco v8.72.

My specs are as follows (to the best of my memory):
Dell 5150 Mobile P4 3.06GHz
UXGA 1600x1200
64MB DDR NVIDIA® GeForce™ FX Go5200 AGP 4x Graphics
DVD drive
40gig HD
Dell TrueMobile 1150 = Orinoco Gold Firmware V8.72

Thanks
Booty 8)

Foon
02-18-2004, 12:02 AM
I've been having the same problem here, and this cheat code works for me as well. Dell Inspiron 5150 with Geforce FX gfx;
knoppix nosmp
boots perfectly.

I've experimented with different BIOSes to see what happens; I tried the 02-16 and 02-09 versions of Knoppix, with BIOS versions A31 (latest), A29 (previous) and A26. All booted perfectly with the nosmp cheatcode.

No idea what I did to get this working, but it does, so I'm happy - don't have to wait for 3.4 to come out :)

moustache
02-24-2004, 02:54 AM
I have downloaded a copy of Knoppix C'T 3.4 from someone's webserver (slow) and booted it on my Dell 5150 laptop with just the following at the boot prompt:
knoppix26 lang=en
(didn't need "nosmp" this time! but you do need to use shift-0 to get the equal sign because its a german keyboard layout at the bootprompt)
Anyway it booted up fine, recognized the broadcom nic, radeon ati card, the sound card and the USB ports!
As "windows_no_thanks" was saying, it may be because i have the latest version of the dell bios (A31) on my laptop. Be sure to get it from the dell support download page.

Moustache

booty
02-29-2004, 07:12 PM
Well what is it about these new versions of Knoppix that makes them work with the 5150? Or are you saying that A31 bios fixed the problem? I don't think I'm upgraded to A31 but I could be wrong.

I'm just curious, but in the end I'm really just happy that it works. Even if i don't know how!

redeagle
03-03-2004, 10:19 PM
hey i got inpirion 5100, it has two nics one is the truemobile 1300 wifi, i cant get to work, i think it is just setup problem with me not knowing what i am doing...

thanks allot this looks really kewl if i can get the internet and networking working

yellowtrolley
03-15-2004, 05:36 PM
THANKS A LOT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

redeagle
03-16-2004, 11:15 PM
kk im still not having any luck on the 5150, not sure what bios i am running

how do u do this cheatcode thing u guys are talking about

please remember im a noob and have no idea what ur talking about so spell it out for me

thanks allot

windos_no_thanks
03-17-2004, 04:58 AM
kk im still not having any luck on the 5150, not sure what bios i am running

how do u do this cheatcode thing u guys are talking about

At the boot prompt (that comes up almost immediately when booting and has the Knoppix logo in the background) type "knoppix nosmp" enter. Like this:


boot: knoppix nosmp

For some people this seems to work while it does nothing for others but it doesn't take long to try it so it is a good starting point. :-)

redeagle
03-19-2004, 02:26 AM
ok i entered the knoppix nosmp at the boot and still no go for the wifi..

knoppix works and everything booting this way or regular but it only sees the eth0 network card and not the wifi card..

im using a blitz wifi router with dhcp serving on.. course the lan is 192.168.1.xxx, i dont see anywhere in the router for the gateway, im assuming this is setup to the actual router ip.. i am sure it would work on the lan with eth0 and cat5 but that does me no good..

can anyone help me get this working i really need it to work for studying purposes.. it sounds like there are many with my exact setup... anyways, i appreciate all the help

i appologize it is a 5100 not a 5150 with the truemobile card

Slaithen
04-09-2004, 05:46 PM
For all of you who still couldn't get the 5150 to boot knoppix, I figured it out. I had been using Knoppix-3.3-2-16-2004-EN and it never worked, even with the nosmp cheat code. However, when I downloaded the 2/09/04 release and booted it, IT WORKED!. WooooHOOO!! :D

So, make sure you update to the latest bios, at this time it is A32. Use the nosmp cheat code, and make sure you use the 2/09/04 release.

Hope this helps someone out there.

Slaithen

redeagle
04-10-2004, 03:22 AM
is there still no help for the wirless truemobile card on the 5100 i boot to live cd fine but i cant get on the net on the wireless, really really need to but dont know what i am doing loll

plz help someone if it is possible

Slaithen
04-12-2004, 07:10 AM
To my knowledge the only way to get the truemobile card to work is with the driverloader module from www.linuxant.com, or maybe ndiswrapper. But as far as getting these to work with Knoppix. I don't think so.

I have driverloader working fine with a debian install on the Inspiron 5150, but it isn't free. You get a 30 day trial but then you have to buy it.

good luck

Slaithen