PDA

View Full Version : MBR issue



elqueso
02-13-2004, 05:05 AM
I've got this problem with booting up (might be MBR might not be). Here's what happened.

I installed XP pro SP1 about 2 weeks ago and at the same time I installed Debian 3.02r on another partition. Made the bad move of allowing lilo to take over the mbr. After a week or so, I realized I didn't need debian and that I needed space. So I made a really stupid move of using partition magic to take over all of the non-NTFS space. This worked fine and I was happy for a few days. Until I decided to shut my computer down for the night. (I usually kept it on.) The next morning when I started it up I got a screen filled with 40's (the number 40 scrolling across the screen on every line). I figured it was something wrong with the boot so I looked up stuff online. I found the fixmbr and fixboot things for the xp recovery system. Ran both and then tried to change the bootcfg file. I rebooted and I got the message "Operating system not found." I've been on KNOPPIX for a while trying to find the solution. The other day I decided to hell with my harddrive and formatted the entire thing and went for a clean install of Windows XP professional SP1. Installation went okay until the point in which I had to reboot. System rebooted and then gave me the same Operating system not found message. After this point, I've tried everything. Hard drive installation of knx (with lilo taking over mbr and without). Tried installing debian again (with and without lilo taking over mbr). All this has been to no avail. It always just tells me "Operating system not found." I'm pretty sure the harddrive isn't physically defective (It's a fairly new computer) Any ideas on how I can get past the Operating System not found message? Thanks!

Edit: The system I'm on is a laptop and doesn't have a floppy drive. I don't have a 98 cd so I can't try the fdisk /mbr thing.

baldyeti
02-13-2004, 10:54 AM
Did you check (eg with cfdisk) that you have one (and only one) partition marked as active (bootable), and that it is the one you want (the XP one if I followed correctly).

elqueso
02-13-2004, 04:59 PM
Right now I've got Knoppix as the only bootable partition on the C drive. (the other partition is the swap file and the rest of the hard drive is unpartitioned). Lilo's currently supposed to be in the MBR, whether it is or isn't I don't know.

newnovice
03-18-2004, 12:14 AM
do one thing man, to restore the MBR for just booting windows, thrown in that Windows XP CD and boot from it, and choose to repair the install pressing 'R' key when asked for. and this will ask u for the Administrators password and then u will get at a command prompt like

C:\ WINDOWS\

so here u just type 'fixboot' - this will rewrite a new MBR and this will make only the C partition with Windows XP bootable and just type 'exit' and restart and everything shud be fine, let us know how it goes. u might wanna reformat the other partition from inside Windows XP, using computer management from administrative tools !

cheers....

newNovice.