View Full Version : Bug in latest Knoppix?

02-14-2004, 05:18 PM
I downloaded the 2-9-2004 version and installed to the hard drive. Upon booting, the KDM login screen came up, but when I tried to login to any window manager or KDE, the screen went blank for a second and then KDM appeared again. This happened if I tried to login as root or as a regular user. I had a version from 11-19-2003 and installed it to the hard drive and everything worked. Could this be a bug? Has anyone else had a similar problem?

02-14-2004, 08:36 PM
I have the exact same problem. I haven't filed a bug report yet since I want to try troubleshooting it myself.

If you try a console login, then startx, you will see the Xserver error messages, most of them having to do with /usr/X11R6/lib/modules/extensions/libGLcore.a and fonts/libspeedo.a. Note that X was compiled from Linux 2.4.23-pre6 rather than 2.4.24.

This is why I keep two 5Gb partitions for Knoppix. On one partition, I keep a "stable" install of Knoppix 3.2 (the 2003-07-26 one) which I've never had problems with. On the other partition, I install the latest Knoppix release (using the fromhd boot option so I don't waste CDs) and experiment with package installations, kernel recompiles etc.

02-15-2004, 02:46 AM
I noticed the same errors when trying to start X from the console. I think Xfree 86 in the 2-9-04 version is newer than in the 11-19-03 version. I tried editing XF86Config-4 to change video drivers from "ati" to "vesa" and tried removing the lines loading glx, dri, and other stuff. None of the changes I made enabled me to get X to start. I re-installed Knoppix using the 11-19-03 CD. Perhaps I will post this to the Debian-Knoppix list.

02-16-2004, 02:54 PM

I posted to the debian-knoppix list and Klaus Knopper replied that it was probably an error in Xsession scripts. Yesterday, he found the problem, fixed it and released a new version (2-16-2004) that should be on the mirrors soon. The new version also corrects some other bugs. I am very impressed that Klaus Knopper took the time to respond and fix things.

02-16-2004, 07:47 PM
Is it possible to upgrade this somehow, or do I have to download the new release and install all over again?

02-16-2004, 09:27 PM
In his e-mail reply, Klaus Knopper suggested a work around for the problem:

However, I seem to have found the problem with the non-working X-Login. It seems that the scripts in /etc/X11/Xsession.d have changed somehow, so you get NO desktop manager if there is a "default" line in $HOME/.wmrc. I fixed this in the upcoming update, but an easy way for a workaround is just loggin in with the "failsafe" login (or text console),
and doing an

echo "kde3" > .wmrc

-Klaus Knopper[/quote]

02-16-2004, 10:07 PM
Ah ok, thanks for the info. I don't think I've had that problem- I installed gnome and use gdm as the default.

02-22-2004, 08:12 PM

Thanks for doing the legwork on this.