View Full Version : Can't access floppy as regular user

02-14-2004, 07:53 PM
I've done a hard drive install of Knoppix 3.2 and created a regular user which seems to working fine except I can't access the floppy. I mount the floppy as root and I can read from and write to it. When I try to read it as regular user it says permission denied. My user is in the floppy group and I've compared my fstab file with others I've seen on here and else where and it seems to be correct
Any help would be appreciated.

02-14-2004, 08:50 PM

man chmod

For a simple fix (although I wouldn't recommend using this too randomly)

chmod 777 /floppy (or wherever your floppy drive is mounted)

will allow everyone to access the floppy drive.

02-14-2004, 09:41 PM
Thanks for the quick reply.
I tried that but still no access as regular user.

02-18-2004, 09:14 PM
I reinstalled and changed a few things, and I'm getting access to the floppy. I went with the graphical login and I haven't done any updates yet. I have a couple of new questions now.

1 I'm not sure if I ran the chmod 777 command. I've looked at the info chmod and man chmod and they don't say anything about numbers. Is there somewhere I can look to see if the mode is set to 777?

2 I mounted the floppy and looked at it with Konquerer. One of the files on the floppy is a copy of a Kword document. I
made some changes to the copy on my harddrive then I wanted to save a copy on my floppy. When I tried to save as from Kword it said the device a: was busy try again. I umounted the floppy and then Kword was able to save it. Does this sound right?

This whole mount business is starting to drive me nuts!