PDA

View Full Version : compilation problems



knoppy
02-16-2004, 02:50 PM
I have been working with knoppix 11-19-03 (on hd) for a few months and I am very happy with it! I was able to compile kshowmail. However, when I try to compile an additional program I get the following message:

grep: /usr/lib/libXft.la: No such file or directory
/bin/sed: can't read /usr/lib/libXft.la: No such file or directory
libtool: link: `/usr/lib/libXft.la' is not a valid libtool archive
make[3]: *** [libk3bdevice.la] Fehler 1

Any suggestions? Thanks in advance!

PS: I have installed the ATI-Radion driver. I originally thought that that was the problem, but I am no longer convinced, as this message comes up after a few compilation attempts anyway...

Stephen
02-16-2004, 07:14 PM
I have been working with knoppix 11-19-03 (on hd) for a few months and I am very happy with it! I was able to compile kshowmail. However, when I try to compile an additional program I get the following message:

grep: /usr/lib/libXft.la: No such file or directory
/bin/sed: can't read /usr/lib/libXft.la: No such file or directory
libtool: link: `/usr/lib/libXft.la' is not a valid libtool archive
make[3]: *** [libk3bdevice.la] Fehler 1

Any suggestions? Thanks in advance!

PS: I have installed the ATI-Radion driver. I originally thought that that was the problem, but I am no longer convinced, as this message comes up after a few compilation attempts anyway...

Looks like you do not have the libxft-dev package installed you need to install it.


HappyTux:/home/stephen# dpkg -S libXft.la
dpkg: *libXft.la* not found.
HappyTux:/home/stephen# apt-file search libXft.la
libxft-dev: usr/lib/libXft.la
libxft-dev: usr/lib/libXft.la

knoppy
02-17-2004, 07:55 AM
Thanks, Stephen

Did as you told me. However, I'm getting a new error message:

/usr/bin/ld: cannot find -lXinerama_pic
collect2: ld returned 1 exit status
make[2]: *** [kshowmail] Fehler 1

How do I go on from here...?

Stephen
02-17-2004, 08:58 AM
Thanks, Stephen

Did as you told me. However, I'm getting a new error message:

/usr/bin/ld: cannot find -lXinerama_pic
collect2: ld returned 1 exit status
make[2]: *** [kshowmail] Fehler 1

How do I go on from here...?

You now need xlibs-pic and you really should install apt-file then you can get the answer you need in seconds on your system. :wink:


HappyTux:/home/stephen# apt-file search Xinerama_pic
xlibs-pic: usr/X11R6/lib/libXinerama_pic.a
xlibs-pic: usr/X11R6/lib/libXinerama_pic.a

knoppy
02-19-2004, 01:05 PM
Well, Stephen, thanks for the hint. I installed apt-file... a great tool (took me a right while to find out I needed to do an update first!)

However, even aften an apt-get -t unstable install xlibs-pic my knoppix wouldn't compile.
As a matter of fact, the whole affair is rather strange. Originally, I was able to compile kshowmail and kickPIM (and another few apps), but at one stage knoppix started to refuse compilation.
When I restore an older image file, knoppix compiles again.

Well, it is possible that knoppix has problems with an updated library (but I don't know exactly what I have updated...)

Stephen
02-19-2004, 08:34 PM
Well, Stephen, thanks for the hint. I installed apt-file... a great tool (took me a right while to find out I needed to do an update first!)

However, even aften an apt-get -t unstable install xlibs-pic my knoppix wouldn't compile.
As a matter of fact, the whole affair is rather strange. Originally, I was able to compile kshowmail and kickPIM (and another few apps), but at one stage knoppix started to refuse compilation.
When I restore an older image file, knoppix compiles again.

Well, it is possible that knoppix has problems with an updated library (but I don't know exactly what I have updated...)

Sorry about that should have mentioned it, I would say your right it looks like there is some kind of bug getting in there try installing apt-listbugs and while your at it apt-listchanges then when you install the packages go and check the bug reports for each package installed and see if there is something in there that may help. BTW http://bugs.debian.org for the bug tracking system. The error(s) you are getting may be helpful to post as well.