PDA

View Full Version : apt-get ERROR



foggy
02-20-2004, 11:01 PM
Hi!
I'm trying to update my Knoppix 3.3 (kernel 2.6.1) but I have some problems with APT:

# apt-get update

Hit http://security.debian.org testing/updates/main Packages
Hit http://security.debian.org testing/updates/main Release
Hit http://security.debian.org testing/updates/contrib Packages
Hit http://security.debian.org testing/updates/contrib Release
Hit http://security.debian.org testing/updates/non-free Packages
Hit http://security.debian.org testing/updates/non-free Release
Hit http://security.debian.org testing/updates/main Sources
Hit http://security.debian.org testing/updates/main Release
Hit http://security.debian.org testing/updates/contrib Sources
Hit http://security.debian.org testing/updates/contrib Release
Hit http://non-us.debian.org sid/non-US/main Packages
Hit http://non-us.debian.org sid/non-US/main Release
Hit http://non-us.debian.org sid/non-US/contrib Packages
Hit http://non-us.debian.org sid/non-US/contrib Release
Hit http://non-us.debian.org sid/non-US/non-free Packages
Hit http://non-us.debian.org sid/non-US/non-free Release
Hit http://non-us.debian.org sid/non-US/main Sources
Hit http://non-us.debian.org sid/non-US/main Release
Hit http://non-us.debian.org sid/non-US/contrib Sources
Hit http://non-us.debian.org sid/non-US/contrib Release
Hit http://security.debian.org testing/updates/non-free Sources
Hit http://security.debian.org testing/updates/non-free Release
Hit http://non-us.debian.org sid/non-US/non-free Sources
Hit http://non-us.debian.org sid/non-US/non-free Release
Hit http://ftp.us.debian.org sid/main Packages
Hit http://ftp.us.debian.org sid/main Release
Hit http://ftp.us.debian.org sid/non-free Packages
Hit http://ftp.us.debian.org sid/non-free Release
Hit http://ftp.us.debian.org sid/contrib Packages
Hit http://ftp.us.debian.org sid/contrib Release
Hit http://ftp.us.debian.org sid/main Sources
Hit http://ftp.us.debian.org sid/main Release
Hit http://ftp.us.debian.org sid/non-free Sources
Hit http://ftp.us.debian.org sid/non-free Release
Hit http://ftp.us.debian.org sid/contrib Sources
Hit http://ftp.us.debian.org sid/contrib Release
Reading Package Lists... Done

# apt-get upgrade


Reading Package Lists... Done
E: Read error - read (21 Is a directory)


# dpkg --status apt
Package: apt
Status: install ok installed
Priority: standard
Section: base
Installed-Size: 2692
Maintainer: APT Development Team <deity@lists.debian.org>
Version: 0.5.22
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: libapt-pkg-libc6.3-5-3.3
Depends: libc6 (>= 2.3.2.ds1-4), libgcc1 (>= 1:3.3.2-1), libstdc++5 (>= 1:3.3.2-1)
Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
It provides the apt-get utility and APT dselect method that provides a
simpler, safer way to install and upgrade packages.
.
APT features complete installation ordering, multiple source capability
and several other unique features, see the Users Guide in apt-doc.


Anybody can help me?
TIA