PDA

View Full Version : 02/09/2004 HD Install and captive-NTFS working?



Durand Hicks
02-22-2004, 10:32 PM
Hello all,

After acquiring this version of Knoppix, I installed it to my hard drive and managed to get past the gui problems. Then I compiled a whole new 2.4.24 kernel using the Debian sources successfully so that it was streamlined specifically for my IBM thinkpad laptop. 3 days later, I successfully compiled the thinkpad sources as part of my kernel, forcing a recompile as a matter of course. This allowed me to use tpctl to customize my power management. However, I couldn't get tpb to work, something to do with the fact that the osd fonts 10x20 isn't found on my hard drive, so I gave up on that for now. 3 days ago, I found out I needed ALSA to get sound working, as the oss driver didn't work even though dmesg said it was the correct card. So I had to get the sources for ALSA and complie that into the kernel (remember to apt-get remove knx-alsa first then apt-get install alsa-base and alsa-source), which forced yet another kernel recompile.

Then last night, whist reading about the captive-ntfs function that was enabled in the 3.4 c't version of Knoppix, I had to try and install the captive-ntfs too. I didn't compile the sources this time, but used the debian files from the website. After some errors, I had to apt-get remove a couple of things from Knoppix in order to get the captive-ntfs installed and working. Needless to say, I got it working, once I found out that in order to mount using the captive driver, I deleted the original hd icons from the desktop and created new ones based on captive-ntfs, and it worked. Alas, it crashed the alsa driver making my laptop generate a piercing noise so loud, (I didn't hear it, I didn't have my hearing aid on at the time) that I had to power cycle it off. A reboot into the same kernel produced the same error so that meant my kernel took a beating. Off I went and recomplied it again with the alsa and thinkpad sources. I'll say this though, captive-ntfs worked, but the warning screens gives me the heebie jeebies, have anyone used the captive-ntfs driver and not gotten any warnings and how did you go about getting captive-ntfs to work with the 2.4.24 kernel without breaking the other programs or even the kernel? One last question, how did Klaus (or any of you) optimize the boot sequence? I'd like to know so I can do the same.