PDA

View Full Version : FIXED, thanks!



brinstar117
02-29-2004, 07:23 AM
Good day all!

I have been thoroughly impressed with what Linux and especially Knoppix has to offer. I have been a Windows user for 7 years (grew up with it without exposure to other OS'es).

I have been trying to get Knoppix 3.3 installed on to an older system. Its specifications are as follows:

Intel PR440FX Dual Socket 8 (Dual Pentium Pro)
2X Pentium Pro Overdrive processors (PII 333MHz Klamath core, 512KB full speed L2)
4X 256MB EDO ECC Buffered DIMMs
Adaptec ANA-6944A/TX 4 Port PCI NIC
160GB Maxtor D540X hard drive

During the file copying process, the system halts and this message appears:

unable to handle kernel paging request at virtual address 02000000 printing eip: c013dc28
Oops: 0002
autofs4 af_packet efs hsf minix nls_iso8859-1 ntfs xfs reiserfs ext3 jbd cs4232 ad1848 uart401 sound

soundcore tulip crc32 serial usb-uhci usbcore apm rtc cloop

CPU: 0
EIP: 0010:[<c013dc28>] Not tainted
EFLAGS: 00010246
eax: 00000000 ebx: d21b7d90 ecx: d31b7d90 edx: 02000000
esi: d31b7df0 edi: d31b7d90 ebp: c1395210 esp: c1c23f24
ds: 0018 es: 0018 ss: 0018
Process kswapd (pid: 5, stackpage=c1c23000)
Stack: (8 columns and 3 rows of 8 digit groups of numbers and letters, looks like a memory address)
Call Trace: (more eight digit series of numbers with brackets)

Code 89 02 c7 41 30 00 00 00 00 51 e8 81 ff ff ff 83 c4 04 04 c3 90




Though I am not sure, it seems that I have a hardware problem. The first line mentions a problem with virtual memory. Is that in reference to the swap partition? I find it difficult to believe that my hard drive is faulty because I have tried to install on more than one hard drive with this system, but the same problem keeps reappearing. Also, I have tried a hard drive from a failed install on this setup and successfully installed Knoppix on the hard drive with a different computer.

My next guess would be that I have a faulty DIMM somewhere. I sincerely hope that this isn't the case, but I will try to factor out the variables. I have run multiple loops of Memtest86 on the DIMMs and all have passed without a problem.

I just want to see if you guys have any ideas as I have limited experience with Linux. In the meantime, I'll try to factor out the DIMMs by trying to install with only one DIMM at a time.

Thanks for any help!

EDIT: I forgot to mention that Knoppix boots successfully as a Live CD, (even detects and properly configures the ancient 4 port NIC - Awesome!). I have played around a little in that mode, but prefer to have it on a hard drive now, which brings me to this situation.

EDIT 2: I was able to successfully install Knoppix. All I did was take out all but one DIMM and everything proceeded normally. I will test the other DIMMs as I go along later. This edit was made off my new Knoppix box!

RockMumbles
03-01-2004, 12:46 AM
Get on the internet and do a search for memtest86, and make a memtest floppy.

Untar the memtest86-3.0.tar.gz file by using (assuming you also get version 3.0 if you get a newer version use that version number:

tar -zxvf memtest86-3.0.tar.gz

then:
cd memtest86-3.0
and (as root) place a floppy disk into your floppy drive and issue the following command:
dd if=precomp.bin of=/dev/fd0
which will write the precompiled binary to a floppy (Note: /dev/fd0 is f d zero)

then put your second stick of ram into your box and boot to the memtest floppy, so it can test your ram.

HTH

~rock