PDA

View Full Version : cann't start kde as user



jackren
02-29-2004, 10:12 AM
Hi all, I had some problem with my windowmanagers(installed wdm but that totaly locked my keyboard, unstalled it and installed gdm )
Now I cannot start kde as user. I can start it (kde) as root and everthing works fine.
It has probably nothing to do with X-server cause I can start icewm,fluxbox,xfce... as user.
When I try to start kde as user , the kde startup logo comes up but when "
inithilasing perhipicals" it stops and I get a kde-crash window that say something about: ksmserver signal :11 (SIGSEGV)
Anybody any ideas how to fix this?

fingers99
02-29-2004, 05:40 PM
Try re-creating the user (as root, in kde) using Kuser (Kmenu > System > Kuser).

jackren
02-29-2004, 10:33 PM
I created a new user with Kuser , and I could login to kde as that user just fine.
Now I made backup of my home dir and re-created my account with Kuser(first deledted it and than created it with same name and password)
But still same problem, cann't log in to kde as user (=only my useraccount)

fingers99
02-29-2004, 11:29 PM
OK, it looks like you've an issue with one of the .directories or .files which tells the WMs what to do (can't remember which one!). I'd be inclined to copy all the files except the hidden ones from your problem user's home directory to somewhere safe, blitz your problem user's home directory and re-create with Kuser. Then copy the files over. You may need to mess with the permissions (of these copied over directories) as root.

RockMumbles
03-01-2004, 12:34 AM
log into the user account in a console (or other wm and open an X terminal program)
and do an:

ls -alR .kde | less

look carefully at the username and group name. If you see that there are some files with messed up username or group name then do this:

cd .kde

then:

su

and give the root password, then;

chown -R user.group *

in the above chown command substitute your username for user and your group for group.

If that doesn't fix your problem then rename your home .kde directory to .kde-old and restart kde and it will make a new .kde directory for you.

HTH
~rock

jackren
03-01-2004, 06:03 PM
I loged into my useraccount under Xfce4 and did : ls -alR .kde | less
It looked ok, all owner and group where "jack" which is my user account only
I few entrys had "501" for owner.
Then as root: chown -R jack.jack * (first cd /home/jack/.kde ofcourse)
But problem is stil there , cant login to kde as user jack.
Then renamed .kde to .kde-old , but still no fix.
I'm afraid I've to delete my home dir and create new one.
What's the best way to save my settings?

jackren
03-04-2004, 12:45 PM
finger 99 wrote

OK, it looks like you've an issue with one of the .directories or .files which tells the WMs what to do (can't remember which one!). I'd be inclined to copy all the files except the hidden ones from your problem user's home directory to somewhere safe, blitz your problem user's home directory and re-create with Kuser. Then copy the files over. You may need to mess with the permissions (of these copied over directories) as root.

I tried this but I don't wanna loose all the hidden files from my home dir.
( just try copy them back one by one to see where the problem is)
I did - chown -R jack.jack * - in my home dir after I copied back most files and
dir of my old home dir. This set ownership of al files and dir s right ,but not of
the hidden files, I there a linux-command to chown al hidden files and hidden-subdirectories of a dir all at ones?

RockMumbles
03-04-2004, 05:25 PM
I did - chown -R jack.jack * - in my home dir

for dot (hidden) files

chown -R jack.jack *.*

~rock

jackren
03-05-2004, 09:49 PM
I recreated my useraccount and copied all the files and dir I needed and weren't corrupted from my backup, set all permissions right and all works well
again.

THANKS FOR THE HELP