PDA

View Full Version : troubles with locales



macherb
03-03-2004, 10:25 AM
Hi,

I still fiddle around with my Knoppix-derived debian system. I want to get rid of German messages, menues, titles,....
A "locale" command lists all LC_ and the LANG command: in German. Then I export LC_ALL and LANG to en_US (Yes, the locales are installed, and I stay in the same console-window), a "locale" command lists, as expected, all variables set to en_US. But when I open e.g. gftp all menues are in German, when I open e.g. dselect all dialogs are in German. This behaviour is not native to debian and makes no sense, since it has to be possible to change the locale for a specific application.
Hence my question: Where is this behaviour defined and how to remove these persistent settings?

Thanks
macherb

RockMumbles
03-04-2004, 06:17 PM
Using dselect, is it in german when in a console? or when in an x-terminal (running in a gui)?

What window manager or desktop environment are you using?

Window managers and desktop environments can use a different settings for the language than settings used for console.

You might want to install localepurge which when configured will remove any unncecessary locales from your system when adding or updating packages, this should fix your console behaviour.

apt-get install localepurge (you may need to use apt-get -t unstable install localepurge to get localepurge from unstable)

Note: it's always a good idea to use: apt-get install -s localepurge to simulate the install so you can see what apt is going to do...

~rock

macherb
03-05-2004, 12:08 PM
OK, I've deleted now de_DE with localepurge. But thats only cosmetic, because the system simply cannot find what it wants to load, hence an error is displayed: cannot set LC_CTYPE, no such file or directory (or similar). There appear to exist more problems: The first one occurs whith booting: There now the locale (i.e. de_DE) is not found (Which script is running there? Is it a Knoppix-script or a normal debian-script?)
The problem with exporting locales persists. Now everything is in english, but exporting LAN=de_DE still has no consequences. (e.g. I need a special program in German and start with a script ssetting LANG to German). So it seems the locale is completely screwed up. Is this a Knoppix derived problem?

BTW, switching of consoles with Ctrl-Alt-F<number> is not possible. A Knoppix feature?

regards
macherb

RockMumbles
03-06-2004, 07:21 AM
As far as your locale problem, look and see if you have an /etc/sysconfig/i18n file and if it exists, see what lang it is set.

As far as the ctrl-alt-f1 etc. they should work in knoppix.
Maybe have a look at: /etc/init.d/keymap.sh and see what it is loading

~rock