PDA

View Full Version : ok...walk me through this...cdrom and cdrom1



Silver_Seagull
03-10-2004, 08:57 PM
Hello, my name is Silver_Seagull and I am a Linux noob.

OK, got Knoppix on its own partition (knx-hdinstall - ver 3.3 old) with a dual-boot LILO with Win XP home.

Got my GeForce 4 Ti4400 all drivered-up (nvidia drivers installed and working :D )

Can't get Knoppix (Debian technically I suppose) to recognize my optical drives. The drives are a DVD-ROM as master on the second IDE controller and a slave Yamaha CDR-F1 on the same cable. All the jumpers are in right etc...they work fine in Win-blows....I mean, Windows. ;) :p

Now here's the curve-ball...I've dropped a DVD into the drive and have Ogle and Xine installed with libdvdcss 1.2.8....the DVD runs like shite (16x player..go figure) but that's for another thread. The thing is tho, it RUNS it. I can also start up K3B and have it recognize both drives and burn stuff to the Yamaha @ its top speed of 44x.

But I CANNOT, for the life of me, get it to mount the drives separately. You know, like as icons on the desktop...or even access them outside of the above mentioned programs.....

help would be much appreciated. :)

Cheers

Loper
03-10-2004, 10:24 PM
Can't get Knoppix (Debian technically I suppose) to recognize my optical drives. The drives are a DVD-ROM as master on the second IDE controller and a slave Yamaha CDR-F1 on the same cable. All the jumpers are in right etc...they work fine in Win-blows....I mean, Windows. ;) :p

Now here's the curve-ball...I've dropped a DVD into the drive and have Ogle and Xine installed with libdvdcss 1.2.8....the DVD runs like shite (16x player..go figure) but that's for another thread. The thing is tho, it RUNS it. I can also start up K3B and have it recognize both drives and burn stuff to the Yamaha @ its top speed of 44x.
These problems have already been solved many times over. You need to do a search on this site and in the FAQs for fstab for the mount problem and hdparm and DMA for the DVD skipping problem.

Silver_Seagull
03-11-2004, 01:59 AM
thanks for the reply....I did look and try the stuff on the site and it didn't seem to help....for some reason, I just booted and it seems to work....ty tho.

As for the DVD skipping problem....I have looked around and nothing seems to help....the hdparm -d1 /dev/cdrom OR /dev/dvd don't work because I get this:

# hdparm -d1 /dev/cdrom

/dev/cdrom:
operation not supported on SCSI disks


And I am left sittingthere thinking WTF. It's an IDE cable, channel and Windows sees them as IDE as well (I checked to make sure I wasn't crazy)

Ideas?

rickenbacherus
03-11-2004, 04:22 AM
thanks for the reply....I did look and try the stuff on the site and it didn't seem to help....for some reason, I just booted and it seems to work....ty tho.

As for the DVD skipping problem....I have looked around and nothing seems to help....the hdparm -d1 /dev/cdrom OR /dev/dvd don't work because I get this:

# hdparm -d1 /dev/cdrom

/dev/cdrom:
operation not supported on SCSI disks


And I am left sittingthere thinking WTF. It's an IDE cable, channel and Windows sees them as IDE as well (I checked to make sure I wasn't crazy)

Ideas?

What kernel are you using?

uname -r

Linux uses scsi emulation to access cdrom drives (no longer true w/ kernel 2.6.*). That's why they are seen as SCSI drives.

Try this:

cdrecord -scanbus

ls -al /dev/cdrom

/dev/cdrom should be a symlink pointing to your actual drive.

Try

hdparm -d /dev/scd0

(or wherever your drive is on the SCSI BUS).

Silver_Seagull
03-11-2004, 11:52 PM
ok, I tried what you said. My kernel is 2.4.24-xfs

this is what I get when I try the ls-al /dev/cdrom and then the hdparm thing

# ls -al /dev/cdrom
lrwxrwxrwx 1 root root 9 Mar 10 12:30 /dev/cdrom -> /dev/scd0
root@Box:~# hdparm -d /dev/scd0

/dev/scd0:
operation not supported on SCSI disks

When I did the scanbus I got the following (I'm working as su for this)


Linux sg driver version: 3.1.25
Using libscg version 'schily-0.8'.
scsibus0:
0,0,0 0) 'IDE-DVD ' 'ROM 16x ' 'HD08' Removable CD-ROM
0,1,0 1) 'YAMAHA ' 'CRW-F1E ' '1.0f' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *


All I want is for the DVD drive to be DMA-enabled...I'll admit I'm lost...what to do?

Stephen
03-12-2004, 12:18 AM
Try using /dev/hdc that should enable the dma on the actual device. Use as root hdparm /dev/hdc to see the settings before you change the setting to make sure it is not already enabled if this is the case then there is some other problem.

Silver_Seagull
03-12-2004, 01:12 AM
sounds like a plan stephen....

um, how do I do that? I got an error message from hdparm that looks like there's no device on hdc...but how do I do what you were saying about changing it to hdc? fstab? and if so, what do I change?

Stephen
03-12-2004, 02:07 AM
sounds like a plan stephen....

um, how do I do that? I got an error message from hdparm that looks like there's no device on hdc...but how do I do what you were saying about changing it to hdc? fstab? and if so, what do I change?

You do not have to change the /etc/fstab setting just use what is already there. You should make sure the link for the /dev/dvd points to the /dev/scd0. Can we see the output of the command here is what it looks like on my system.



>$ su
Password:
HappyTux:/home/stephen# hdparm /dev/hdc

/dev/hdc:
HDIO_GET_MULTCOUNT failed: Invalid argument
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Invalid argument

HappyTux:/home/stephen# hdparm -d1 /dev/hdc

/dev/hdc:
setting using_dma to 1 (on)
using_dma = 1 (on)

HappyTux:/home/stephen# hdparm -d1 /dev/cdrom

/dev/cdrom:
operation not supported on SCSI disks

HappyTux:/home/stephen# hdparm -d1 /dev/dvd

/dev/dvd:
operation not supported on SCSI disks


HappyTux:/home/stephen# cdrecord --scanbus
Cdrecord-Clone 2.01a25 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Linux sg driver version: 3.5.30
Using libscg version 'schily-0.8'.
scsibus0:
0,0,0 0) 'HL-DT-ST' 'DVDRAM GSA-4040B' 'A104' Removable CD-ROM
0,1,0 1) *

HappyTux:/home/stephen# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

/dev/scd0 /cdrom iso9660 ro,user,noauto 0 0

HappyTux:/home/stephen# ls -l /dev/dvd
lrwxrwxrwx 1 root root 9 2004-03-06 23:41 /dev/dvd -> /dev/scd0



If you need to set the dma you should make the changes in the file /etc/hdparm.conf with something like this.


/dev/hdc {
dma = on
interrupt_unmask = on
}


At the bottom of the file.

Silver_Seagull
03-12-2004, 04:48 AM
ok, I'm really really sorry, but I don't get what you mean stephen...I'm really that green :(

I tried following what you did in the example but nothing seemed to change (yes I rebooted) this is what it is set up as now.

# cdrecord -scanbus
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.8'.
scsibus0:
0,0,0 0) 'IDE-DVD ' 'ROM 16x ' 'HD08' Removable CD-ROM
0,1,0 1) 'YAMAHA ' 'CRW-F1E ' '1.0f' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

# filesystem mountpoint type options dump pass
/dev/hda2 / xfs defaults 0 1
/dev/hda3 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdrom1 /cdrom1 iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/scd0 /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,umask=000 0 0

/dev/dvd:
operation not supported on SCSI disks

/dev/cdrom:
operation not supported on SCSI disks

/dev/cdrom1:
operation not supported on SCSI disks

I am honestly lost as to what I need to do. I'm really sorry to be eating up your time with my stupid questions.. :(

Stephen
03-12-2004, 07:38 AM
That is ok, what does hdparm /dev/hdc and hdparm -d1 /dev/hdc say those are the important commands for me to see and you are root when you are doing the commands right? Oh and this is not windows you really do not have to reboot for many procedures you will get used to it after awhile especially when you install software.

Silver_Seagull
03-12-2004, 10:27 PM
ok, here is what I get with hdparm /dev/hdc and hdparm -d /dev/hdc

root@Silver'sBox:~# hdparm /dev/hdc

/dev/hdc:
HDIO_GET_MULTCOUNT failed: Invalid argument
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 1 (on)
readahead = 8 (on)
HDIO_GETGEO failed: Invalid argument
root@Silver'sBox:~# hdparm -d1 /dev/hdc

/dev/hdc:
setting using_dma to 1 (on)
using_dma = 1 (on)

so confused....

Stephen
03-13-2004, 05:14 AM
ok, here is what I get with hdparm /dev/hdc and hdparm -d /dev/hdc

root@Silver'sBox:~# hdparm /dev/hdc

/dev/hdc:
HDIO_GET_MULTCOUNT failed: Invalid argument
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 1 (on)
readahead = 8 (on)
HDIO_GETGEO failed: Invalid argument
root@Silver'sBox:~# hdparm -d1 /dev/hdc

/dev/hdc:
setting using_dma to 1 (on)
using_dma = 1 (on)

so confused....

Ok that is what I needed to see the DMA will work on your machine you now just need to edit either the /etc/init.d/bootmisc.sh file and put these two line near the bottom the exit 0 one will already be there.


## Added by me for DMA on DVD player
hdparm -qd1 /dev/hdc

: exit 0


Or you can put it in the proper file the /etc/hdparm.conf in the format I posted above and everytime you boot the DMA will be set on the drive and you should get better playback.

Silver_Seagull
03-14-2004, 03:17 AM
/me cries.... :cry:

I am _so_ sorry. I still have no idea what I'm to change what to.

What do you mean the "link for the /dev/dvd points to the /dev/scd0" ? Is that the /dev/dvd should be changed to /dev/scd0 or /dvd should be changed to /scd0 ?

also, my fstab has *no* mention of 'hdc'.....what is it exactly? Do I need to change something?

I feel like such a moron. :(

I guess I need you to spell it out in baby steps....anyone who actually understood this..step by silly, stupid step.

Again, I'm _so_ sorry I'm such an idiot.

Silver_Seagull
03-15-2004, 02:23 AM
:edit:

nvm....Got it!!!

Thx for all the help!