View Full Version : LILO problem

03-14-2004, 12:02 AM
ok heres the spot:
I downloaded Knoppix using a live cd on a system which had WIN XP already on it. after i finished, rebooted my pc: i got the LILO menu but with only Knoppix as a choice. Realizing that i couldnt boot WIN XP anymore i messed around with lilo.config (i cant exactly remember wat i did) but the next time i rebooted i didnt get the menu anymore and from that point on, my pc only booted WIN XP. So now i have Knoppix on my system but i cant reach it. So what do i do now? I installed red hat on my laptop and it worked perfectly. in the GRUB menu i could choose between the 2 OS how can i do the same thing here?

03-14-2004, 04:59 AM
You may fix it with knoppix live-cd
Use forum search.
Search for ´chroot´

03-14-2004, 05:09 AM
or you could do what I did when faced with the same problem and no other computer.....re-install the knoppix to the same partition you did last time.....fixed LILO (obviously lol) and found the XP mbr too!

but I suspect what oscar said is more...."finessed" :)

03-14-2004, 04:37 PM
Well, it's hard to say with so little detail, but it could very well be that you simply installed knoppix to its own parttion, and did not install lilo to MBR. Then you simply need to toggle the active parttion. To that effect, boot off the CD, then type "sudo cfdisk" from a shell prompt.

Otherwise, assuming you installed to hdaN (you need to remember or find out the numerical value of N), you can:
1) boot from CD "knoppix 2" (console mode)
2) cd /tmp; mkdir K; mount /dev/hdaN K
3) chroot /tmp/K
4) edit /etc/lilo.conf (use mcedit if you are not used to vi)
read the lilo man page if you need to
(knoppix normally puts lots of comments within the file)
5) run lilo -v
Pay attention to error messages; if all is well you're set to reboot.

Good luck,


03-14-2004, 05:07 PM
hey i tried the procedure described in the subject "install dual os" that is on this forum it worked like a charm! but i noticed that wen u install knoppix on hdd u get it in a much more primitive manner than wen its run live i mean i still couldnt get the mouse to function and nusin is mounted i cant access the windows hard disks yet the live cd version has everything automated...