View Full Version : GRUB ... then nothing

03-15-2004, 04:30 AM

I am new to the Linux world and KNOPPIX was my first experience with Linux. I was impressed with it and tried to install it on my hdd. All went well until i reboot. I get to the prompt "GRUB" and then nothing happens. Can someone please help me out with this?

Thanks in advance


03-16-2004, 01:42 PM
have you found an solution?

you say you see grub, but (I havent used knoppix lately so I can be wrong) knoppix uses LILO nog grub. So what knoppix are you using? and you see grub, what exactly do you see?

03-16-2004, 01:59 PM
Hi superstoned,

That was what I thought too. I was baffled to see GRUB prompt greeting me. I THINK that I got over the initial problem I was having. I have had my hdd as the secondary master (there are no primary master or slave, my comp's interior is in a mess and ... I just got too lazy to move my hdd around) and after reading some of the postings, one of them pointed out that I could modify the lilo.conf. So I did and changed boot=/dev/hda to boot=/dev/hdc.

From then on, KNOPPIX loaded ... half way and I get some error message about bad CRC on my hdd and stops. I can't really remember the exact error message right now though. Therefore, I suspect there is something wrong with the hdd but I have been using it for some time and it works.

So, is what I did at the begining (altering the .conf file) the correct thing to do? Or would it have caused some CRC problem (??) to my hdd?

Thanks in advance.

03-16-2004, 02:06 PM
well, its unlikely your disk is broken (or, part of it) but not impossible.

anyway, I'd start moving your hdisk to a propper place (e.g. primary master), it might help. I've seen alot of problems with these things too, esp with raid-hardware present in the system.

and what you did with the conf file is oke, it shouldnt give problems. but you have to re-run lilo for the new config to be applied (guess you did, it worked isnt it?)