View Full Version : I want to install KNOPPIX on an NTFS drive---help!

03-15-2004, 05:16 PM
Hel;lo...I have a new HDD that was given to me. It had WINXP on it. I formatted that drive and now it is clean. Except its still NTFS!!!! I tried to do a 'KNX-hddinstall' from the KNOPPIX CD but i got a little way thru it and it kept coming up saying "No swap partition found, select another drive". I have 2 HDD's in the computer. The other HDD is a regular WINXP drive. So How Can i install KNOPPIX to this NTFS drive? I have a COMPAQ laptop that had WIN98 on it. KNOPPIX installed on that computer perfectly. But I am still not too sure about the menu screen that comes up with the options, similar to DOS's "FDISK"....maybe I did something wrong. I let knoppix cd boot entirely, bring up a root console and type in "knx-hdinstall" and I get partially thru till i get to the part that asks if I want to "use the current swap partition" or something like that. Please HELP!!!! BOB

03-16-2004, 04:46 AM
Just say 'no swap' partition & when you get to the cfisk part of the install use that to partition & format the new HD. Or if that doesn't work, run Knoppix from CD & use cfdisk to format the HD. Partition it so you have about 3-4 gig for the lInux o/s (Knoppix needs 2.4 Gig min, 4 is lots), allow about 300 meg for swap & format the rest 'vfat' which is the Windows 95/98/ME format. You need the vfat for a shared data drive accessible to both XP & Linux as Linux is not reliable writing to XP's NTFS format.
Alternatively, make a boot disk from your win98 laptop with Windows fdisk on it & use that to boot your computer & partition/format the HD with fdisk.
What Knoppix do you have? If it's 3.3, use the 'knoppix-installer' command instead of 'knx-hdinstall'.

03-17-2004, 07:25 PM
Thanks for advice from all....I did manage to get Linux installed working perfectly! I just need to get the CD player to play at a louder volume! I have a regular cd rom and also a cd writable drive. But in Linux, for some reason I can only play music cd's in the writable drive! If I put a cd in the regular cd and bring up player i get error saying "no media found" or something like that. The regular cd rom does read a cd with photos on it for example. It just wont play music. And the writable drive, when you play music on cd, the volume is extremely LOW.....I tried configuring sound and other options but its too low to use. Any ideas????? Thanks...bob

03-18-2004, 05:58 AM
For the sound thing, two steps. First, click on Kmenu > Multimedia > Sound > Kmix. The Kmix icon (a sort of speaker thingy) should appear on your taskbar (usually on the RH side). Right click on this, select "Show Mixer Window" and whack up the volume under the CD icon.

Second, KsCD (the application you use to play music CDs in Kde) has a horizontal volume control of its own. (Often missed!)

I'm pretty sure the "other thing" is the result of a missing (or incorrect) symlink. You might like to google for something like


03-18-2004, 07:17 PM
Thanks Fingers99.....I was monkeying around with it last night and did get it to work finally. But I noticed an error or two. There is a command, the name of it i forgot, but you go to console and type in the command to bring up a file of all that text that scrolls by real fast on monitor when you boot up LINUX. I noticed there are 2 references to my soundcard and to another related sound option that comes up at the very end as errors. I will bring it into work tomorrow and copy and paste it here on the forum to see if anyone can help with it. My cd player seems to be working ok with the cd player program. Volume is a good loud level now. The only thing i noticed was the music didnt seem to be in stereo! But it could be that I have a crappy audio plug on speakers and it might be not fully mated. And I noticed that if i put a picture cd in the cdrom and click on the cdrom icon, it gives a error in a small box in middle of screen. I did have it working before so i will mess with it some more tonite. Anyway it seems that mounting & unmounting the cdrom is important! I have to get used to this!.....ok...bob

03-19-2004, 12:56 PM
Thanks for suggestions people! I have discovered that my sound card is not supported!!! I do have good sound and cd player is working fine I assume cause Linux drivers are helping.....

03-19-2004, 01:05 PM
Do you have an audio cable between one cd-rom and the soundcard.
In that case you get direct sound from it without any drivers.
That would also explain why you only get sound from one cd-drive.

03-19-2004, 08:06 PM
I do have a cable on both the regular CD rom and the RW cd rom going to mutha board......I do have a slight problem with sound on my laptop though....the cd player program works perfect....BUT if I right click on the cdrom icon on desktop, there is a choice to "play a music cd" and it brings up a cool looking X MULTIMEDIA SYSTEM player! But the music is stuttering badly....how do i fix that? Any ideas? Music plays perfectly in th regular CD PLAYER program tho.....