View Full Version : how can I disable my non-existant floppy? It's causes hang

03-16-2004, 12:34 AM
Complete newbie to linux here. I have a DELL Latitude laptop (C540 I think, if you're interested). I recently installed Knoppix to my HDD (I know, now it's Debian, not Knoppix) using knoppix-installer. Works fine. I have an external firewire HDD which works fine too, now that I'm using that rescan script. My problem is that because my laptop DOESN'T have a floppy drive, anytime I try to switch to /mnt/exthdd in an app's "open file" dialog box, after typing in "/mnt", my computer freezes for 5 to 10 minutes. A little investigation reveals that it's trying to see what's on my non-existent floppy drive. If I do 'ls /mnt', I see 'floppy' there in the list. So my question is how can I remove my floppy, so that linux won't look for it anymore?

Before posting this, I googled for solutions for this for a few hours. All I found was someone else who had the same problem, but no solutions. Any help you can give me would be greatly appreciated.

Thanks in advance,


03-16-2004, 11:14 AM
Add this line in /etc/modutils/aliases:

alias block-major-2 off and then reboot.

03-16-2004, 09:48 PM
Add this line in /etc/modutils/aliases:

alias block-major-2 off and then reboot.

And you would want to update-modules as root as well to update the /etc/modules.conf with the changes so they will be used on the next boot.

03-17-2004, 02:48 AM
Thanks Stephan. Been a while since I've messed with those files on my machine.

03-18-2004, 02:34 PM
Thanks guys for your help. I did as you said, but unfortunately the problem still exists. Any other ideas?

03-19-2004, 03:17 AM
Have you rebooted or anything? Try this and see if it returns a line with block-major-2:

$ grep off /etc/modules.conf

03-19-2004, 09:09 AM
Don't you normally disable an unwanted floppy in the BIOS?

03-19-2004, 02:27 PM
yes, it shows

alias block-major-2 off

and yes, I've rebooted. in my bios (ie if I hit F2 when the computer's booting up) it shows both floppy disk A and B as disabled, but that doesn't help any.

Some more information:

When my computer freezes the way I described, if I hit ctrl-alt-F1, I the following on the screen:

end-request: I/O error, dev 02:00 (floppy), sector 0
end-request: I/O error, dev 02:00 (floppy), sector 1
end-request: I/O error, dev 02:00 (floppy), sector 2
end-request: I/O error, dev 02:00 (floppy), sector 3
end-request: I/O error, dev 02:00 (floppy), sector 4

About two minutes pass between the computer's displaying of each of those lines. The whole time, back in my GUI, everything's frozen. Finally, when it unfreezes, it's in the /mnt directory, and "floppy" appears as one of the FILES, not one of the subdirectories.

Finally, I forgot to mention that when I did "update-modules" like you said, I got the following error:

depmod: *** Unresolved symbols in /lib/modules/2.4.22-xfs/kernel/drivers/char/drm/gamma.o

I appreciate all your help. Maybe there's something else I can do?

Thanks again,


03-20-2004, 07:57 AM
It almost sounds like dd is trying to image the floppy when you start up! Do you have any floppy module? Perhaps you could remove that. You'd still have errors in the log but probably wouldn't freeze. You could always rebuild the kernel and take out floppy support. The gamma.o shouldn't be a problem (at least not related to the floppy issue).

03-20-2004, 06:48 PM
I had a similar problem on my Thinkpad (no floppy), where anytime you went to /mnt the system hung for several minutes. My cheesy fix was to delete /mnt/floppy, which did the trick for me.

03-20-2004, 06:50 PM
I forgot to mention that to delete /mnt/floppy I had to type the command "rm -f /mnt/floppy" quickly, or the system hung for a couple minutes while typing the command (something to do with the command completion, I think). I also had to use the -f switch, because otherwise the system hung for a couple minutes while asking for confirmation.

03-21-2004, 07:20 AM
Sounds like an issue I had with a laptop install of Kanotix a while back. Here's the fix Kano gave me (which always works for me)...

Disable the automounter:

/etc/init.d/autofs stop

And to remove it from starting automatically:

update-rc.d -f autofs remove

03-28-2004, 11:42 PM
Hi -

The last two solutions (deleting the "floppy" file, and disabling the automounter) seemed to work for me. So I went with the deletion, since permanently disabling the automounter just doesn't sound like a good idea.

Thanks so much for all your help,


04-13-2004, 01:59 AM
But how to proceed if using a livecd ?
I have the same problem using a livecd on a dell cpi,cpt latitude laptop.
When browsing graphically in KDE the automounter does it's job and goes trough all mnt list .
Can I delete the /mnt/floppy from a read-only system ?