PDA

View Full Version : Help: Getting 3d Acc on recent ATI card



Jack_
03-16-2004, 12:57 PM
Could someone who had success installing the current ATI video drivers help.

I've downloaded the recent drivers and used alien to install them, but need help to go from there.

I read on rage3d's how to step 11,
http://www.rage3d.com/content/articles/atilinuxhowto/Linux_ATI.html
I need
fglrx-driver.rpm
where is that found?

Also, Im using Knoppix 3.4 c't, what kernal does it use, do I need the sources?

Any help, walking though the install would be great....

Jack_
03-16-2004, 08:18 PM
Here's the error I receive:

root@Knoppix34ct:/lib/modules/fglrx/build_mod# ./make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.4.23-xfs/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.

Markus
03-16-2004, 08:26 PM
Haven't tried, but there's a script here:
http://kano.mipooh.net/

Jack_
03-17-2004, 12:54 AM
After trying for the last 2 days to follow 3 pages of instructions, I took your advice and ran Kano's script... 3d working perfect now!

Thanks for the tip and thanks to Kano for the excellent script!