PDA

View Full Version : Need Help! - Startx from boot ?



Juztin
03-18-2004, 12:45 AM
Hello everyone,

I'm using Knoppix to make old pc's and laptops into linux thin terminals which will launch an ICA session.

Here's my problem:

I need the distro installed on the HD to boot directly to a Xsession which will automatically start "wfica" <-- Citrix ICA Linux client

So in essence the machine will look just like a thin terminal.

I have been clawing at this beast for hours trying to figure out this seemingly simple issue. A display manger seem to need to prompt for a login, however I can't allow any kind of linux login prompt because there's already too much things for the user to do. I editect xinitrc to automatically run /usr/lib/ICAClient/wfica . So when I type in "startx" after logging in as root I get the boot to Citrix client look. Which is exactly what I want.

However to get that far I have to log in as root :( . I need the distro to simply load up and go directly to launching the /usr/lib/ICAClient/wfica binary. I've tried adding /usr/X11R6/bin/startx to the inittab in which case I get a ton of errors. The X server starts but then errors with an "ApplicationServer" not defined or something like that. However after the computer loads and I login as root, I can run startx just fine?

It looks to me like the system doesn't know where the files are, I went ahead and exported a bunch of directories as a test and I got a different set of errors, but it looked like it was partially resolved, but the Xserver still crashed cause of the errors.

Does anyone have an idea of how to get 'startx' to run upon boot without the massive errors?

I played a bit with kdm but I had an error about "wmaker" file could not be opened, and I have the "wmaker" package installed! (I believe I was trying to run icewm as the desktop manager)

I tried adding "local" to /etc/init.d/ with an entry of "exec /usr/X11R6/bin/startx" to no avail as I read up that Debian uses that file as opposed to rc.local

(I'm a Debian noob b.t.w)

Thanks for any help you guys can provide, hopefully by tomarrow! :cry:

--j2

Juztin
03-18-2004, 01:35 AM
Hello again,

Just wanted to let you guys know not to bother with this issue anymore. I finally resolved it by implementing a shell script 8)

--j2