View Full Version : webcam on Knoppix

03-18-2004, 02:06 PM
Anybody any idea how to get my Creative webcam to work ?

03-18-2004, 03:13 PM
This might help a bit.

Most webcams use one of a few chips made by the same big manufacturers, they sell them bulk to comanies who box them up into cameras, different brands and prices, same thing inside!

I assume it's USB. Open a console and type in dmesg -c this will list lots of message and clear them. Next plug your webcam in and type dmesg -c again. What happens next depends.....

If it says something to the effect of:

usb.c: USB device 2 (vend/prod 0xc77/0x1002) is not claimed by any active driver

- then you need to find a driver - try using the "0xc77/0x1002" and do a search on google

If it tells you what you've plugged in, then you should try out xawtv and see if you can get a picture.


03-18-2004, 04:04 PM
it actually tells me USB device 3 (vend/prod 0x5a0/0x518) is not claimed by any active driver,
and then proceeds to register ov511 V1.63 for Linux 2.4 : ov511 USB Camera Driver

But no dice on xawtv, it can't open a viedeo grabber device.


03-18-2004, 04:17 PM
Okay, thanks good (except for no picture!) - what it means is your camera is recognised and you do have a driver (if you look on google with a search of "ov511 linux" - you'll see what I mean).


Try from the console

xawtv -c /dev/video


xawtv -c /dev/video0

If that doesn't work check the xawtv commands by doing

man xawtv

Good luck!


03-18-2004, 04:24 PM
Stu, that's what I did :

knoppix@ttyp0[knoppix]$ xawtv -c /dev/video
This is xawtv-3.91, running on Linux/i686 (2.4.24-xfs)
can't open /dev/video: Function not implemented
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video: Function not implemented
v4l2: open /dev/video: Function not implemented
v4l: open /dev/video: Function not implemented
no video grabber device available

and mesg shows :
apm: BIOS not found.
ov511.c: No decompressor available
ov511.c: No decompressor available
ov511.c: No decompressor available
ov511.c: No decompressor available
ov511.c: No decompressor available
ov511.c: No decompressor available
ov511.c: No decompressor available
ov511.c: No decompressor available
apm: BIOS not found.


03-18-2004, 04:26 PM
Sorry, I'm stuck now.

Hopefully someone else on the forum or look on google for

"ov511.c: No decompressor available"


03-18-2004, 05:19 PM
googled and found I surely need an updated driver, but then that means I have to install on the HDD first to be able to install such.


04-13-2004, 02:23 AM

You can stop and start the ov511 driver with certain parameters.
Take a look at this site : http://alpha.dyndns.org/ov511/download/ov511_1.49.txt

It comes always with first stopping the usb service and starting it afterwards.

Good luck ...

04-21-2004, 08:38 AM
I asked some questions about webcams in Linux a few months ago in this forum and had a few comments, none of which worked. So far, I've managed to get an ov511 type (PC-EYE) to function under SuSE 8.2 (only) with gqcam. Since then, I have failed with an 0x41e (Creative badged) and an 0x506 (3Com badged). Neither of these worked reliably and satisafactorily under 'doze, either, even with the supplied drivers; they were dropped PDQ. Now I see a plethora of requests for help with similar units on many Linux websites, most with nil or minimal response. Huge quantities of webcams containing these sensors seem to have been dumped into the marketplace.
It occurs to me that there were two common 'budget' sensors in the supply chain a year or so ago; these were eagerly packaged by the usual suspects of greedy badgers with hopelessly inadequate support, even under Windows. One of these elements (ov511?) can sometimes be made to function under Linux, but only by the IT fraternity capable of following detailed instructions for console editing, directory entry manipulation and if they are adept with tarballs and the suchlike (ie a tiny minority of putative users). There are quite a few suggestions on a couple of Linux-usb websites, but these still appear to have worked only for a few.
From all of it this, it would seem that there is one sensor type in particular that no-one can make function under Linux and that no-one in the Linux community has been able or willing to get to grips with.
Perhaps - perhaps - a new K3.4 with 2.6 kernel will radically improve USB access? But the camera list also needs updating for generic types and I don't see this happening for obsolute kit. Sadly, the industry seem to have generated another collection of plastic dinosaurs ready for landfill and downstream planet pollution unless someone can persuade a keen Linux coder to accept this very considerable intellectual challenge.....