View Full Version : Help with swap partition

03-19-2004, 12:53 PM
Hello....I am wondering about my swap partition. It doesn't seem like its being used. My HD is a 40G. I partitioned it first with a 1G partition, type 'swap'. Then made a 2nd partition, the remainder of space left, type 'linux' set bootable....saved & exited CFDISK....then went about with rest of installation. Everything is mostly running perfect. I ran QPARTED just to take a look at the partitions. I noticed my 1G partition for swap was still NTFS! The drive was formerly a WINXP drive. When I started out i deleted the NTFS partition so I think! But anyway, I used the utility in qparted to turn it into a ext3 or linus stsyem and the little penguin showed up to the left of partition data just like below on the line for my other partiton that i set for linus thats bootable. I ranINFO CENTER and noticed under swap space it said "not available". It shows both partitions as ext3...../dev/hdb1 is: swap size is 949.12MB status is ? theres nothing in the space for 'status' ... used space is 63.50 start is 0.03 MB and end is 949.15MB ..../dev/hdb2 is: ext3....status is active.....size is 36.34GB used space is 3.96GB...start is 949.15MB end is 37.27GB......this seems to not be right somehow......should the 'status' of the swap partition be ACTIVE? I would guess so....how do i fix this so Linux uses the correct swap partition???? Thanks...bob

03-19-2004, 01:18 PM
It's a while since I've made a swap partition, but a quick search here gives this:
mkswap /dev/hd?? (to make the filesys once you have the partition).
Substitute ?? for your actual device for swap.
swapon -a (to turn it on).

03-19-2004, 04:31 PM
Hi Marcus! I tried that then all hell broke loose!!!! Hhahahaha! I re-Installed Knoppix this time using "knx-hdinstall" and the whole thing turned out much much better than using the other "knoppix-installer" program. Now everything is cool, except i cant seem to get my clock to show the right hour....its 6 hours slow! I tried to adjust the time zone and i set it for America/New York but it wont take on the lower right clock next to the date. I wonder why? bob

03-19-2004, 05:44 PM
Hmm, Sorry! :(
Best I don't try to give advice on the time thing.

03-19-2004, 08:31 PM
Markus, you just forgot to mention that there should be an empty partition that will get turned into swap. or a "swapfile" a'la DOS, not a great solution but... it is slow and prone to other trouble, not to mention somewhat hard to get working.

03-19-2004, 08:40 PM

And thanks for setting me straight.

03-19-2004, 11:31 PM
Check in the file /etc/default/rcS and see if the UTC setting is set to yes if so change it to no, either that or change the time in the BIOS to be set to the proper GMT(UTC) time.

HappyTux:/home/stephen# grep -r UTC /etc/*
/etc/default/rcS:# Set UTC=yes if your system clock is set to UTC (GMT), and UTC=no if not.
[snip ...]